useless "select all" context menu entry on right click message pane when no message selected (e.g. in an empty folder)

RESOLVED FIXED in Thunderbird 14.0

Status

Thunderbird
Message Reader UI
--
trivial
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: der_tuxman, Assigned: Magnus Melin)

Tracking

Trunk
Thunderbird 14.0
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Version 2.0.0.16 (20080708)

Hi,

I just right-clicked into the message pane with no actual message selected and I got a menu with one entry, "select all" ("Alles auswählen", as I'm German)...

Now I wonder what it's for... maybe this should be changed?

Reproducible: Always

Steps to Reproduce:
1. Start TB without a message selected
2. Right-click the empty message pane
Actual Results:  
A useless menu item appears :)


Here's a screenshot:

http://img3.imagebanana.com/img/46n8ttzb/wtf.png

HTH
(Assignee)

Comment 1

9 years ago
Confirming on linux/trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: useless "select all" context menu entry → useless "select all" context menu entry on right click message pane when no message selected (e.g. in an empty folder)

Comment 2

6 years ago
On the other hand, if even this item gets removed, the menu will be completely empty. It would look something like a 5x5px square. Would that be better?
Or should it then be completely hidden?
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
Version: unspecified → Trunk
(Reporter)

Comment 3

6 years ago
+1 for "hidden".
(Assignee)

Comment 4

6 years ago
Created attachment 604786 [details] [diff] [review]
proposed fix
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #604786 - Flags: review?(squibblyflabbetydoo)

Comment 5

6 years ago
Comment on attachment 604786 [details] [diff] [review]
proposed fix

Review of attachment 604786 [details] [diff] [review]:
-----------------------------------------------------------------

This breaks the context menu in the start page (and possibly elsewhere), so we probably need something a bit more complicated to detect this.

On the other hand, if we ever merge Mail Summaries into Thunderbird, this won't matter, since the message pane should never be blank then.
Attachment #604786 - Flags: review?(squibblyflabbetydoo) → review-
(Assignee)

Comment 6

6 years ago
Created attachment 607273 [details] [diff] [review]
proposed fix v2

Yeah i always forget about the start page...
Attachment #604786 - Attachment is obsolete: true
Attachment #607273 - Flags: review?(squibblyflabbetydoo)

Comment 7

5 years ago
Comment on attachment 607273 [details] [diff] [review]
proposed fix v2

Review of attachment 607273 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry about the delay. I've tried this out and it seems to work.
Attachment #607273 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 8

5 years ago
http://hg.mozilla.org/comm-central/rev/b8464bdff27c -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 14.0
You need to log in before you can comment on or make changes to this bug.