deal with bugmail threading and change default for mail.thread_without_re

RESOLVED FIXED in Thunderbird 3.0b2

Status

P2
normal
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: davida, Assigned: philor)

Tracking

Trunk
Thunderbird 3.0b2
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
In order to prevent false positive threading of messages that are not related except that they share a subject line (e.g. "introduction"), I think that we should change the default of mail.thread_without_re to false.
Flags: wanted-thunderbird3+
(Reporter)

Comment 1

10 years ago
Note that one issue with setting that pref to false is that e.g. bugmail doesn't get threaded, as bugmail doesn't include reference headers.  

I wonder if a pref that grouped in threads for "long" subject lines would be a better heuristic.  I don't have a particular definition of long in mind.

Comment 2

10 years ago
or maybe group messages from the same sender?
Bugzilla should be fixed to include a References header.
Bugmail does include references/in-reply-to headers.  The trick is that (as sent by bugzilla.mozilla.org) every message includes the same 'phantom' message-id (no message ever has this message-id).  I sorta suspect that's a bug, but it at least causes gloda to lump them in the same conversation.  (It treats the phantom message as a 'ghost' message which all of the bugmails are replies to.)
Er, I realize my wording was potentially ambiguous.  To clarify, each bugmail message for bug NNNNN references/in-reply-to's a made-up message-id like "bug-NNNNN-yyyyy" where I have no clue what the yyyy is, but it is always the same for all messages generated by that bug.  The actual message-id of each message appears to be randomly allocated by one of potentially many mail-servers.
So the bug is that bugs with same "References:" headers doesn't thread? Shouldn't they? 

Re comment 2, would have to be the actual "Sender: " then. E.g. launchpad sets commenter name as "From: ".

Updating summary, as we can't change the default without bugmail threading working out of the box.

leaving wanted‑thunderbird3+ for now. asuth: want to take this?
Priority: -- → P2
Summary: Change default for mail.thread_without_re → deal with bugmail threading and change default for mail.thread_without_re
Target Milestone: --- → Thunderbird 3.0b2

Comment 7

10 years ago
Magnus, that's possible - messages with the same References: header don't thread together, if there's no message with that header as a message-id.

Comment 8

10 years ago
but it's possible that they do in "correct threading" mode, which is a hidden pref.
You're right, mail.strict_threading threads bugmail! 

A few years back outlook (or was that exchange) used to skip generating Message-Id headers which made the pref fairly unusable. But luckily that seems to have changed, so enabling it might be one solution. Though just making the current threading work when the References: are identical but the original is missing should also go a long way.

BTW, this should be a duplicate of bug 164115.

Comment 10

10 years ago
opting for blocking 164115, because it has a radically different and more recognizable summary
Blocks: 164115

Updated

10 years ago
Duplicate of this bug: 464061
=TRIAGE=
Still wanted, moving off target older milestone.
Target Milestone: Thunderbird 3.0b1 → ---
Interestingly enough, it appears that mail.thread_without_re now has a default value of "false" in Shredder builds from 2009-01-13 forward -- was that supposed to happen?

(I only noticed that as part of trying to narrow down bug 473439, in which threading for bugmail / threading by subject appears to be broken in general.)

Comment 14

10 years ago
that was intentional, to see how many people were relying on threading w/o re.
I claim the checkin comment for that experiment could have been a bit more descriptive than "add archive folder command" ;)
(In reply to comment #4)
> sent by bugzilla.mozilla.org) every message includes the same 'phantom'
> message-id (no message ever has this message-id).  I sorta suspect that's a

FTR, the comment 0 bugmail "[Bug ...] New: ..." does have that Message-ID.

On the premise of this bug -- disabling thread_without_re won't stop false positive threading of unrelated messages that do have "Re:", will it? That should mean bug 164115 matches the intent of comment 0 here. Setting 

    strict_threading=true correct_threading=true thread_without_re=false

then restarting, and rebuilding folder indices, seems to do the right thing -- bugmail is threaded also across subject changes without real ref-parent, and messages without references having the same subject aren't.
This needs to block, in the sense that an experiment has been started, and we need to finish it.  I suspect the right thing to do is continue the experiment by trying sp3000's suggestion, though I suppose it's conceivable that we'd leave things as they are now.  In any case, we need to make an explicit decision here rather than allowing this to just fall off the radar.  Reassigning to clarkbw for that decision.
Assignee: nobody → clarkbw
Flags: wanted-thunderbird3+ → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b2
Bug 473439 is reverting the pref change for now.

It should be possible to thread the mails that have the same References header, i've assumed that's what this bug is about.
I think the correct step forward here is to continue the experiment one more release, using sp3000's change from comment 16.  If we find that does the correct thing then we keep it or otherwise revert back.
(Assignee)

Comment 20

10 years ago
Created attachment 360038 [details] [diff] [review]
Tweak prefs

It does indeed "deal with bugmail threading and change default for mail.thread_without_re."
Assignee: clarkbw → philringnalda
Status: NEW → ASSIGNED
Attachment #360038 - Flags: superreview?(bienvenu)
Attachment #360038 - Flags: review?(bienvenu)

Updated

10 years ago
Attachment #360038 - Flags: superreview?(bienvenu)
Attachment #360038 - Flags: superreview+
Attachment #360038 - Flags: review?(bienvenu)
Attachment #360038 - Flags: review+

Comment 21

10 years ago
Comment on attachment 360038 [details] [diff] [review]
Tweak prefs

sure, let's give it a try.
(Assignee)

Comment 22

10 years ago
http://hg.mozilla.org/comm-central/rev/fb8823d88515
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 473439

Comment 24

10 years ago
I don't know if this bug needs to be re-opened, but it appears that threading_without_re no longer threads at all!  If that is the only threading option enabled, threads no longer work for messages with the same subject.  If you turn on both threading_without_re and threading_strict are enabled, then it will thread properly.  Was this an intentional effect?
(Assignee)

Comment 25

10 years ago
(In reply to comment #24)
> I don't know if this bug needs to be re-opened

It does not. It would only need to be reopened if it didn't "deal with bugmail threading" or it didn't "change default for mail.thread_without_re."

Updated

10 years ago
Depends on: 479163

Updated

10 years ago
Keywords: relnote
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.