[bn-IN] Migrate CVS over to hg

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Pike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
We'll need a good point to migrate the content in cvs for bn-IN over to an hg repository beneath http://hg.mozilla.org/l10n-central/

Please follow up to this bug when you think you're ready, setting the status whiteboard to a timestamp you'd consider good.

Please don't land content in hg yourself before the initial migration is done, we want to make sure that the initial content in hg maps a cvs tag so that we can fix up hg annotate on the website to refer to cvs blame at one point.

Comment 1

10 years ago
Hi RunaB:

Just an important update:

Code freeze for Firefox 3.1 Beta 1 is in about two weeks from now, with string
freeze coming next week Friday (September 26). We'd love you to be part of that
release, so for that, we should migrate your cvs content over as soon as
possible.

Currently, there are some good 80 strings to be localized from FF 3.0 to FF 3.1
beta 1 pre, which should be doable.

We know that you're likely going to get valuable feedback on the upcoming
Firefox 3.0.2 (beta release) for Bengali, but that's still not ready to release
from the code side, so waiting for that in probably not feasible.

Once we have copied your work over from cvs to hg, you'll need to decide which
patches to land on which tree, and land as planned separately.  This is some
additional work for you, but nevertheless, making Firefox 3.1 Beta 1 will help
your release of Firefox 3.1 a good deal.  Does that seem clear?  If not, please
ask.

We do expect to have one more FF 3.1 beta cycle after FF B1, but only one, so
making B1 is a really good idea.

Please let us know what you think.  We'd like you to move to Hg and that should
happen pretty soon if possible.

Kind regards,

-sethb

Comment 2

10 years ago
Pike,
Can you migrate bn-IN over to Hg.  Runab confirmed today on IRC that she is waiting for migration to check in translations on trunk for FF 3.1 b2.  Sorry if this was delayed due to my note above, not sure if what I wrote was unclear.  Here is the IRC transcript:

[3:22pm] sethb: i noticed we have not migrated to Hg
[3:22pm] sethb: can we do that?
[3:22pm] runab: is'nt Pike going to do that?
[3:22pm] runab: i got that impression from the bug
[3:22pm] sethb: pike can do that.
(Reporter)

Comment 3

10 years ago
Hi Runa, I migrated CVS over to hg, http://hg.mozilla.org/l10n-central/bn-IN/pushloghtml, and added bn-IN to the Firefox 3.1 build. You can see the results of the fx31x tree on http://l10n.mozilla.org/dashboard/?locale=bn-IN.

http://l10n.mozilla.org/buildbot/waterfall builds on push as you're used to, but now creates l10n-merged builds for linux on top of langpacks, so you can download testable bn-IN linux builds even for partial work from http://l10n.mozilla.org/~buildslave/fx31x/.

To find your way around hg, please read https://developer.mozilla.org/En/L10n_on_Mercurial or poke on #l10n or in the newsgroup.

Scheduling information for Firefox 3.1 B2 is on Seth's post in http://groups.google.com/group/mozilla.dev.l10n/browse_frm/thread/2cc6e9bb836e14b3#
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.