If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Conn: launching w/o ethernet interface hangs Mozilla

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: gabriel, Assigned: gordon)

Tracking

Trunk
mozilla0.9.3
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux build 2000070508.

Steps to reproduce:

Start Mozilla without a network.

Click on File|Offline

Actual result: app freezes completely (in fact it freezes my entire gui !)

Expected result: Mozilla goes into offline mode and retrieves the homepage from
the cache.

Comment 1

17 years ago
I am unable to reproduce this with 072808 mozilla m18 build.  Reporter can you 
try this again with a current build.
(Reporter)

Comment 2

17 years ago
Yes I can still reproduce it with the 2000073009 build. Still freezes, still
hangs Enlightenment and X.

Comment 3

17 years ago
Unable to verify this on my Red Hat 6.2 / Gnome / Enlightenment using the latest 
CVS source.

This might be a clue:  If you select File / Work Offline quickly before Mozilla 
gives up looking for the page, the throbber runs forever...  

I think selecting "Work Offline" should cause any network connection attempts to 
immediately stop.

Comment 4

17 years ago
I also cannot reproduce on 2000080104 M17 on Linux.  Using Red Hat 6.2, latest
Gnome and sawfish from Helix.  I am not able to click offline quickly enough to
see the behavior reported by Scott.
(Reporter)

Comment 5

17 years ago
Hmmm, interesting. Why do you need to click quickly ? On my box, with the
network down, Mozilla spins for ages (maybe indefinately) trying to find my
homepage.
(Reporter)

Comment 6

17 years ago
See also: bug 7428.

Comment 7

17 years ago
I am blocked from testing this because of 7428

Comment 8

17 years ago
Starting mozilla (2000092008) without a network causes mozilla to hang for at
least several minutes on my box (I haven't actually checked to see if it
recovers). After plugging the network back in (physically in this case), it
recovers almost straight away. Presumably it is blocking on DNS and/or loading
the home page.

Note - I don't have to click 'offline' for this to happen, it freezes once it
has loaded.

This seems like a dup, I've just got to find it...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
ah ha... I have a dup for you! :) Even though its not the same description, the 
effect is very similar and so I am marking this as dup. Gordon if you disagree 
reopen and take it over. 

*** This bug has been marked as a duplicate of 49990 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
qa to me.

REOPENING:
The target dupe was a Mac-only bug
Status: RESOLVED → REOPENED
QA Contact: tever → benc
Resolution: DUPLICATE → ---
(Reporter)

Comment 11

17 years ago
This looks like it is working now on Linux though.

There are still I couple of problems I see with offline mode, but they should
probably be reported as separate bugs.

Comment 12

17 years ago
gabriel:

can you put an updated set of steps and their results?
(Reporter)

Comment 13

17 years ago
Sure.

Linux build 2001052308.

Shut down network (I use 'ifconfig eth0 down').

Start mozilla.

Click on file|offline (or the little 'offline' icon at the bottom).

Results:
Mozilla does not freeze and it is possible to browse *cached* pages (e.g. by
selecting from bookmarks).



Note: the other problems I was seeing -
as soon as you click on an unvisited link, mozilla stops browsing. The menus
etc, still work, but you can no longer browse even cached pages.

Also, starting up the network, clicking on 'online' I would expect Mozilla to go
into online mode, but it does not seem to work. It doesn't even try the network,
just sits there spinning away...

As I said, these are probably separate bugs (maybe even dupes).

Comment 14

17 years ago
->gordon
Assignee: gagan → gordon
Status: REOPENED → NEW
Target Milestone: --- → mozilla0.9.3
(Reporter)

Comment 15

17 years ago
Looks like one of those other problems has just been fixed - bug 82468 :-) I'll
keep an eye out for the other issue, if I don't find a bug for it, I'll report
it spearately.

If nobody objects, I am closing this as worksforme. Hopefully somebody else can
verify it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME

Comment 16

17 years ago
VERIFIED:
Mozilla 0.9 Linux

I'm changing the summary to reflect a new set of bugs I'm trying to mark so they
are searchabe: (Conn=Connectivity).

I've also changed your summary so that it deals just with the hang, and just w/
the interface being off.

I'm working on writing a test document that deals with these problems in a
systematic fashion:

http://frame.packetgram.com/pktg/mozilla/nettest.html

-verifyme

In this build, I still see the problem described in bug 82468, but it's fixed
after this build, so I'll discuss that there.

If you have additional problems, keep filing them as new bugs.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Summary: Start Moz with no network, click on offline, app. freezes. → Conn: launching w/o ethernet interface hangs Mozilla
You need to log in before you can comment on or make changes to this bug.