[Digg Toolbar] JS Exceptions

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Administration
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre) Gecko/2008080621 Firefox/3.0.2pre

Steps to reproduce:
-> Install the Digg Toolbar
-> Start Firefox with this Extension
--> Various JS Errors in the Debug Output

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this._logService is null" {file: "file:///Users/carstenbook/Library/Application%20Support/Firefox/Profiles/ztxvuryv.default/extensions/%7B671c8440-f787-11dc-95ff-0800200c9a66%7D/components/gsUtilityService.js" line: 277}]' when calling method: [gsIUtilityService::isNullOrEmpty]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://digg/content/toolbar/gsDiggToolbar.js :: anonymous :: line 154"  data: yes]
************************************************************

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this._observerService is null" {file: "chrome://digg/content/events/gsDiggEventViewer.js" line: 126}]' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]
************************************************************

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this._directoryService is null" {file: "file:///Users/carstenbook/Library/Application%20Support/Firefox/Profiles/ztxvuryv.default/extensions/%7B671c8440-f787-11dc-95ff-0800200c9a66%7D/components/gsUtilityService.js" line: 138}]' when calling method: [gsIUtilityService::getExtensionFolder]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Users/carstenbook/Library/Application%20Support/Firefox/Profiles/ztxvuryv.default/extensions/%7B671c8440-f787-11dc-95ff-0800200c9a66%7D/components/gsDiggSQLiteService.js :: anonymous :: line 107"  data: yes]
************************************************************
(Reporter)

Comment 1

9 years ago
Closing this Bug as invalid, because its no Firefox Bug and also cleaning up this Bugzilla Component.

Also Add-on Developer was contacted.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.