Closed Bug 449895 Opened 12 years ago Closed 10 years ago

Add support for copy & paste

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(fennec1.0-)

VERIFIED DUPLICATE of bug 585875
Future
Tracking Status
fennec 1.0- ---

People

(Reporter: dougt, Unassigned)

References

Details

(Keywords: uiwanted)

when I go to www.google.com and enter a search term, i want to be able to use clipboard actions including text selection.
Target Milestone: --- → Fennec A2
Target Milestone: Fennec A2 → Future
Keywords: uiwanted
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0-
Summary: selection in a edit field → Add support for copy & paste
Duplicate of this bug: 501673
From bug 501673:

There should be a possibility to mark text on a page (e.g. for copy & paste).
Copy & paste itself could work like on most shells: the marked text is
automatic placed in the chipboard.
Duplicate of this bug: 507984
Perhaps this bug depends on bug 537438?

+ Why not use CTRL+C on units that have a keyboard, like the n900, to actually copy text? That is how MicroB works. Sometimes I wish to copy text and continue to be on the same page for a while. If I accidentally - or in order to use ubiquity - should mark some new text, I prefer to have it not replace the one I already have in my clipboard.

For keyboardless usage I suggest mark + tap and hold + context menu for "copy" and "search" + Ubiquity!
There is a work around for this found in the maemo forums. Stuart, do you have that link?
Work happening in bug 585875
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585875
Tested in Nightly 8.0a1, Copy and Paste now works.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.