inability to ignore HTML when viewing messages

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Christopher Chin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: 2.0.0.16 (20080707)

The documentation at http://kb.mozillazine.org/Plain_text_e-mail_-_Thunderbird  does a good job of explaining the different options available under View  -->  Message Body As.

What I'm looking for is an option to TRULY ignore html in incoming messages.  If a message has both html and text parts, I would like to prefer the text part, but if there is ONLY an html part, I would like it to be presented as the original plain text -- with unrendered code.

Ideally, if I had everything *my* way, the current "Plain Text" option would be renamed something like "Stripped Text" or something appropriate (since the tags are being stripped out), and a *new* "Plain Text" option would be added which passes the HTML to the view, unrendered.  Or..... the "Plain Text" option could be preserved as-is, and a new "Ignore HTML" option could be added.

Certainly, I could go to "View Message Source" if I wanted to see the nitty gritty... but the point is, I actually like it when HTML-only messages appear as code.  Most of these cases are SPAM, as most of my correspondents use text only, or send both text and html parts.  Seeing html code in my MUA message panel is a pretty good knee-jerk indicator that I should be hitting the "D-key".

I certainly realize that I'm probably in a great minority that would use this feature, but I think that it's valuable.

If this isn't something worth considering for a future release, is there a config tweak that I could perform now to effectively tell Thunderbird to ignore HTML?

Thanks!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
I don't really see much of a use case for adding a "Raw HTML" option to the Message Body As menu. Most people would either want to see the formatted HTML message or a plain version of it without the formatting, and are not familiar with the actual HTML encoding. Thus, putting such an option on the same level as the others may be confusing for these users. More advanced users who want to examine the original source have the Message Source option (CTRL+U shortcut), also if they suspect it to be spam.

I agree that this is not needed.
If you want such a thing then write an extension for that.
marking wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

10 years ago
Thanks for the thoughtful feedback.
I agree, some users may be confused, but I think that most would know figure out that "Raw HTML" (that's a much batter name, thanks) would *not* be what they wan't.

I'm cool with "won't fix" if there's a config twiddle that I could set.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
I find it hard to justify the inclusion of this feature into the core. Even though experienced in HTML, I rarely want to ever see the actual source since most WYSIWYG editors produce horrendous output for HTML.

If your only purpose for this feature is to identify spam (SPAM is a meat product produced by Hormel, spam is unsolicited electronic mail) more readily, then that is baffling. Very few spam that I get cannot be immediately detected as such by the subject or sender.

This seems the perfect opportunity for an extension. CC'ing a few drivers to make the final call.

Comment 5

10 years ago
Agreed with previous posters: this definitely belongs as an extension, not as part of the core.  Resolving WTONFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.