Useless empty message box in Thunderbird Trunk

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Nomis101, Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; de-de) AppleWebKit/526.11 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1a2pre) Gecko/2008073000 Shredder/3.0a2pre

Sometimes I have an empty message box in Thunderbird Trunk. This message box appears only sometimes, not always. There are two cases the message box appears:
1. If you have an free email account from the german provider web.de, you are only allowed to retrieve your emails every 15 minutes. If you are below this time you get a message that you have to wait 15 minutes to retrieve your emails again. In this case I also get this empty message box (after the regular message from web.de).
2. If you start Thunderbird without an internet connection you normally get an error message. In addition to this error message I get in some cases this empty message box too.

I've never seen this empty message box under Thunderbird 2. I have this empty box in Thunderbird 3 since I beginn to use it (January 2008). 

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 333079 [details]
Screenshot ot the empty message box

Updated

10 years ago
Version: unspecified → Trunk

Comment 2

10 years ago
might this missing message be a string that wasn't localized?

Comment 3

10 years ago
Created attachment 341765 [details]
this box shows the missing contents

Screen shot was from BuildID=20081003025724 (Version=3.0b1pre, OSX, German)

After quick test under OSX I can confirm, that the second box comes semetimes after the first error message. The first one is a plain text about the 15 minutes limit.

The second box have attached. It is the password input and check box for permanently store it in password manager. All things are well good localized. The file "chrome/de.jar" is exactly the same as I have under my Linux. The message has the title POP3_PREVIOUSLY_ENTERED_PASSWORD_IS_INVALID_ETC.

I have connected via telnet to the server to check differences. I see, it is difficult for TB to detect wrong password vs. blocked host. Both give "-ERR ..." after the "PASS ..." and for both cases the server terminates the connection directly after ERR-Message.

Here is a session from blocked access:
RX: +OK WEB.DE POP3-Server
TX: USER USERNAME
RX: +OK Bitte Kennwort eingeben/enter password
TX: PASS ********
RX: -ERR FreeMail-Nutzer koennen nur alle 15 Minuten E-Mails ueber POP3 abrufen. Fuer WEB.DE Club-Mitglieder ist POP3 unbegrenzt nutzbar. Mehr Infos: www.clubinfo.web.de
Connection closed by foreign host.

Here is a session with wrong password:
RX: +OK WEB.DE POP3-Server
TX: USER USERNAME
RX: +OK Bitte Kennwort eingeben/enter password
TX: PASS ********
RX: -ERR Benutzer oder Kennwort falsch/user or password wrong
Connection closed by foreign host.

Have checked Version=3.0a2 BuildID=2008072822 (http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/3.0a2-candidates/build1/thunderbird-3.0a2.de.mac.dmg): The second box comes, but not empty.

I confirm, that on TB 2.0.0.6 (Linux) have very rarely seen the second box. But, this comes there too. You can force it by exit and restart TB between the POP3 access to Web.de. If Web.de is blocked at first access after start of TB, then the password input box comes every time. The second box comes not, if TB has one OK access to the POP3 server in same session. This is the difference to TB3 I can see.

Updated

10 years ago
Keywords: regression
(Reporter)

Comment 4

10 years ago
I also get this empty box, while opening Thunderbird with no internet connection.

> The second box have attached. It is the password input and check box for
> permanently store it in password manager. 
Hm, yes. On my mothers Mac (she doesn't store her password in the password manager) this empty message box has also an empty input field.

(In reply to comment #3)
> Created an attachment (id=341765) [details]
> this box shows the missing contents
I get this box also to my empty box. I first get this message and after that my empty box.

Comment 5

10 years ago
(In reply to comment #4)
> I also get this empty box, while opening Thunderbird with no internet
> connection.

The second box is no normal for Web.de, also for no connection at start.
But should not be completely empty you have posted in Comment #1.

Can you please install a resend version (yesterday 3.0a3-candidates).
(Reporter)

Comment 6

10 years ago
I have a recent version. I update my version once per week.
(Reporter)

Comment 7

10 years ago
Today I get this empty box on build 3.0b1pre/Gecko/20081007 
So it is still in. I have four accounts in Thunderbird [2x web.de (POP3, SSL), 1x yahoo.de (POP3, no encryption) 1x arcor.de (POP3, TLS)] and I get this box three times. So maybe it has something to do with encryption.
But web.de is my 'problem child' since I use Thunderbird (a few years now). This account worries me everytime I activate an enryption. So maybe it has something to do with web.de, too (but I have only two web.de accounts and I get this empty box three times).

Comment 8

10 years ago
What you could do to investigate is to get protocol logs for when that happens. See http://wiki.mozilla.org/MailNews:Logging
(Reporter)

Comment 9

10 years ago
Created attachment 342229 [details]
log file, empty box appeared three times, no internet connection

(In reply to comment #8)
> What you could do to investigate is to get protocol logs for when that happens.
> See http://wiki.mozilla.org/MailNews:Logging

OK, I've tried this. I created a script with "NSPR_LOG_MODULES=all:5". Than I started a new version of Thunderbird WITHOUT an internet connection (to trigger the empty message box).  The empty message box appeared three times.
I attached the resulted log file, because it's all Greek to me.
(Reporter)

Comment 10

10 years ago
Is it possible that this has something to do with Bug 348997 ??? The message box in attachment 321609 [details] looks very similar to mine.
(Reporter)

Comment 11

10 years ago
(In reply to comment #10)
> Is it possible that this has something to do with Bug 348997 ??? The message
> box in attachment 321609 [details] looks very similar to mine.

I've also found a message box that looks similar to mine in Bug 338549. So I've build a version of Thunderbird with the patches applied of bug 338549 and 348997 to see if this will prevent my empty message box. But I still get the message box in this patched Thunderbird. So I now think it doesn't have something to do with bug 338549 or 348997.

Comment 12

9 years ago
still see this?
(Reporter)

Comment 13

9 years ago
(In reply to comment #12)
> still see this?
Thanks to remind me to this. I haven't seen this anymore since a few month now. Seems this is fixed, but I'm not 100% sure.
WFM per comment 13
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Duplicate of this bug: 439041
You need to log in before you can comment on or make changes to this bug.