quick launch icon name not updated with firefox application update

RESOLVED WONTFIX

Status

()

--
trivial
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: nickp10, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I installed Firefox 3 Beta 2 on my machine. It created a quick launch icon with the name "Mozilla Firefox 3 Beta 2." I installed the update to upgrade to the the official release of Firefox 3 as well as 3.0.1. However, my quick launch icon still says "Mozilla Firefox 3 Beta 2."

Reproducible: Always

Steps to Reproduce:
1. Install Beta version of Firefox 3 making sure the quick launch icon is checked when installing
2. Update to the latest version of Firefox 3
Actual Results:  
The quick launch icon name remains as "Mozilla Firefox 3 Beta 2"

Expected Results:  
The quick launch icon should have been renamed to "Mozilla Firefox 3"
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → software.update
Summary: quick launch icon name not updated with firefox update → quick launch icon name not updated with firefox application update
We intentionally don't add or modify shortcuts during application update intentionally whether it is for a nightly, beta, or official release and since this is only an issue with beta releases and would potentially cause bugs with official releases where this is unnecessary resolving -> wontfix. This is only done with the installer or when you select "enable access to this program" (Vista it is under Default Programs -> Set Program Access and Computer Defaults).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.