Rendering error: overlapping characters in huge fonts

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Alex Kapranoff, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

Huge fonts are render in such a way that several starting characters from a line are drawn on the same place without any offset!

I made a simple page to demonstate the bug:
http://kapranoff.ru/~kappa/sizebug.html

The screenshot of this page displayed in my browser is attached.

Looks like fonts sized in a narrow corridor around 200px are affected.

Reproducible: Always

Steps to Reproduce:
1. Size a font via CSS property font-size to 200px

Actual Results:  
Bad rendering
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

9 years ago
Created attachment 333108 [details]
Screenshot
(Reporter)

Comment 2

9 years ago
The bug is also present in XUL pages.
(Reporter)

Comment 3

9 years ago
I did two additional checks.

This bug is not due to some extensions -- I started with an empty profile.
This bug is not present on Windows XP.
(Reporter)

Comment 4

9 years ago
Another check -- the bug IS present in Firefox 2.0.0.16 too.

Comment 5

9 years ago
Bug is present in:
Linux version of Firefox 2.0.0.16 (ubuntu build)
Linux version of Firefox 3.0.1 (ubuntu build)
Linux version of Firefox 3.0.1 (Firefox official build)

Bug is not present in:
Windows version of Firefox 2.0.0.16
Windows version of Firefox 3.0.1


I noted that the errors between the official build and the ubuntu build are different. 
Attachment in next message.

Comment 6

9 years ago
Created attachment 333111 [details]
Official firefox build showing a different error than ubuntu build

The image posted already looks like the ubuntu build error. 
This image shows the official firefox build with a slightly different error.
(Reporter)

Comment 7

9 years ago
Created attachment 333118 [details]
Overlapping fixed by selecting a part of the text

I noticed that the rendering is temporarily fixed if you select the right part of a line with your mouse. This is a screenshot. After clearing the selection (by clicking a mouse e.g.) the glitch returns.
(Reporter)

Comment 8

9 years ago
I'm happy to announce that I don't see this bug any more in official Ubuntu 8.10 Firefox (3.0.6)!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
You need to log in before you can comment on or make changes to this bug.