TM: debug build with shell rt benchmark causes bus error with -j

RESOLVED DUPLICATE of bug 449961

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 449961
9 years ago
9 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Benchmark available at: http://people.mozilla.com/~vladimir/misc/rt.tar.gz

run with js -j -f go.js

Running an opt build seems to complete successfully, whereas running a debug build causes a bus error with this stack trace:

#0  0x000f5bdd in nanojit::LIns::isop (this=0x0, o=nanojit::LIR_neartramp) at LIR.h:304
#1  0x00137fc7 in nanojit::LIns::isTramp (this=0x0) at LIR.h:316
#2  0x00132658 in nanojit::LirBufWriter::ensureReferenceable (this=0x211fd0, i=0x0, addedDistance=2) at nanojit/LIR.cpp:245
#3  0x00132d8f in nanojit::LirBufWriter::ins2 (this=0x211fd0, op=nanojit::LIR_x, o1=0x0, o2=0x10002cc) at nanojit/LIR.cpp:333
#4  0x00132fed in nanojit::LirBufWriter::insGuard (this=0x211fd0, op=nanojit::LIR_x, c=0x0, x=0x211fa0) at nanojit/LIR.cpp:357
#5  0x000f7ac7 in nanojit::VerboseWriter::insGuard (this=0x211ff0, op=nanojit::LIR_x, cond=0x0, x=0x211fa0) at LIR.h:506
#6  0x00135d76 in nanojit::CseFilter::insGuard (this=0x212010, v=nanojit::LIR_x, c=0x0, x=0x211fa0) at nanojit/LIR.cpp:1678
#7  0x001345da in nanojit::ExprFilter::insGuard (this=0x212030, v=nanojit::LIR_xf, c=0x1000014, x=0x211fa0) at nanojit/LIR.cpp:828
#8  0x000f5fd3 in nanojit::LirWriter::insGuard (this=0x212040, v=nanojit::LIR_xf, c=0x1000014, x=0x211fa0) at LIR.h:373
#9  0x000e7c3a in TraceRecorder::guard (this=0x211f50, expected=true, cond=0x1000014, exitType=nanojit::BRANCH_EXIT) at jstracer.cpp:1166
#10 0x000e97ce in TraceRecorder::ifop (this=0x211f50) at jstracer.cpp:1873
#11 0x000ecd19 in TraceRecorder::record_JSOP_IFEQ (this=0x211f50) at jstracer.cpp:2539
#12 0x0007be56 in js_Interpret (cx=0x2005f0) at jsopcode.tbl:107
#13 0x00083775 in js_Execute (cx=0x2005f0, chain=0x32b000, script=0x2113c0, down=0x0, flags=0, result=0x0) at jsinterp.cpp:1545
#14 0x00018fc0 in JS_ExecuteScript (cx=0x2005f0, obj=0x32b000, script=0x2113c0, rval=0x0) at jsapi.cpp:4929
#15 0x00003371 in Load (cx=0x2005f0, obj=0x32b000, argc=1, argv=0x806a68, rval=0xbfffd780) at js.cpp:663
#16 0x00084b90 in js_Invoke (cx=0x2005f0, argc=1, vp=0x806a60, flags=2) at jsinterp.cpp:1306
#17 0x00072585 in js_Interpret (cx=0x2005f0) at jsinterp.cpp:4906
#18 0x00083775 in js_Execute (cx=0x2005f0, chain=0x32b000, script=0x2030b0, down=0x0, flags=0, result=0x0) at jsinterp.cpp:1545
#19 0x00018fc0 in JS_ExecuteScript (cx=0x2005f0, obj=0x32b000, script=0x2030b0, rval=0x0) at jsapi.cpp:4929
#20 0x00002cce in Process (cx=0x2005f0, obj=0x32b000, filename=0xbffff710 "go.js", forceTTY=0) at js.cpp:277
#21 0x00008386 in ProcessArgs (cx=0x2005f0, obj=0x32b000, argv=0xbffff5e0, argc=3) at js.cpp:510
#22 0x0000964c in main (argc=3, argv=0xbffff5e0, envp=0xbffff5f0) at js.cpp:3981

Rev is 4ffbe10ff380.
Just fixed this today -- please reopen if it doesn't work if you update, and show the value of op in js_Interpret.

/be
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449961
You need to log in before you can comment on or make changes to this bug.