All users were logged out of Bugzilla on October 13th, 2018

this crashes firefox (flash 9 plugin)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: wvw, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

The above page makes my Firefox crash. It has to do with the flash plugin, but I report it nontheless.

Reproducible: Always

Steps to Reproduce:
1. Go to http://cz.nl/%7Bb9c66df0-6229-4b4c-b941-f4d70c29ab80%7D?s=CZ_gezondleven&t=Default
2. Press Ok in the error-dialogs
3.
Actual Results:  
crash

Expected Results:  
it shouldn't

I saw some references to the flash plugin in the error reports. that's all.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I see the errors but I don't crash, at least not with a new profile. 
See http://kb.mozillazine.org/Firefox_crashes
no crash with  Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.2pre) Gecko/2008081105 GranParadiso/3.0.2pre and Shockwave Flash 9.0 r124

Can you provide a Crash Reporter ID (if you used the Crash Reporter, you should see the id under about:crashes). What Flash Version do you use ? 
Keywords: crash
Version: unspecified → 3.0 Branch
(Reporter)

Comment 3

10 years ago
I use Flash 9.0 r124. The Crash Reporter doesn't start, strangely enough. Is there a way to fix that?

Comment 4

10 years ago
(In reply to comment #3)
> I use Flash 9.0 r124. The Crash Reporter doesn't start, strangely enough. Is
> there a way to fix that?

See bug 422308. Their fix is in Flash 10 and trying that to see if they've already fixed the crash may also be a good idea.
(Reporter)

Comment 5

10 years ago
With Flash 10 it doesn't crash indeed on my machine.

Comment 6

10 years ago
Then I'll close this out then. This is INVALID, as this is not a Mozilla bug but rather yet another plugin crash fixed in Flash 10. Hopefully Adobe will get around to releasing the final version soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 7

10 years ago
I've just noticed, once I've managed to load a page that has embedded flash, I can close and open Firefox repeatedly, probably in less than a second.

However, when I refresh the page it crashes again.

So the problem seems to be in the initialization of the page that contains embedded videos.

Comment 8

10 years ago
ian: https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report but don't use this bug if it crashes flash 10.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: this crashes firefox (flash plugin) → this crashes firefox (flash 9 plugin)
Version: 3.0 Branch → 1.9.0 Branch

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Resolution: INVALID → WORKSFORME
Target Milestone: --- → Aug 2009
Version: 1.9.0 Branch → 9.x

Comment 9

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: Aug 2009 → ---
Version: 9.x → unspecified
You need to log in before you can comment on or make changes to this bug.