Closed Bug 450099 Opened 16 years ago Closed 10 months ago

Add functionality to remove cached HTTP Authentication credentials

Categories

(Firefox :: General, enhancement)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 260839

People

(Reporter: moz-bug, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Firefox is caching user credentials used for HTTP (Basic|Digest) authentication without possibility to remove them from cache without closing the browser. 

Reproducible: Always

Steps to Reproduce:
1. Login to a website requiring HTTP Basic Authentication.
2. Close the tab or navigate to different page. 
3. Return to original page from step 1 and you are authenticated automatically.
Actual Results:  
User is authenticated automagically as designed ;)

Expected Results:  
Please add button to remove the cached credentials for that domain/realm so that user needs to authenticate again.

As far as I'm aware, currently only way removed the cached credentials is using "clear private data", which will do so for all domains/realms.
see bug 287957, which would do it from a script (ordered by the webserver), not just a manual action from the user.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
Whiteboard: [CLOSEME 2010-11-01]
This is no longer relevant. Is is possible to clear credentials using History -> Clear Recent History and selecting "Active Logins". Although this will unfortunately reset all credentials regardless of the page or domain.
Severity: normal → S3
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Duplicate of bug: 260839
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.