Closed Bug 450200 Opened 11 years ago Closed 11 years ago

Border-image not painted in the right spot with drawImage when scrolled down

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 449647

People

(Reporter: martijn.martijn, Unassigned)

Details

(Keywords: fixed1.9.1, testcase)

Attachments

(1 file)

Attached file testcase
Perhaps related to bug 449647?

The testcase uses enhanced privileges.
When clicking on the "doe" button the red cross should be painted in the canvas.
But after scrolling down a bit, you'll notice that doesn't happen anymore, the green boxes seem to move down in the canvas drawImage, the amount you've scrolled down.
Flags: wanted1.9.1? → blocking1.9.1+
Priority: -- → P2
Confirmed on Linux, using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20081001 Minefield/3.1b1pre

Specifically, I get buggy behaior when I *first* scroll down a bit, and *then* click "doe".

I'm pretty sure the underlying bug here is bug 449647 (particularly considering the points in bug 449647 comment 2 about how that bug is affected by scroll-state at page-load-time).  Duping.
Status: NEW → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 449647
Marking fixed1.9.1 given that the duplicate is fixed1.9.1.
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.