Closed Bug 450238 Opened 13 years ago Closed 13 years ago

Vertical scroll bar on divs not responding to default direction

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: roger, Unassigned)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

See http://forums.mozillazine.org/viewtopic.php?f=25&t=729805

The scrollbar on the left column of my site http://search.rogerlovejoy.net is on the right, when it is designed to be on the left

It was fine in Fx1.5 and2 and is OK in IE5,6,7

The code is applied to the div that contains the data, so the scroll bar should be on the left.

Code: Select all
    #international{
    left:2%;
    direction:rtl;
    font-family:verdana;
    }

Reproducible: Always

Steps to Reproduce:
1. Go to my site
2. check css code
3. See forum topic for details
Component: Build Config → General
QA Contact: build.config → general
Confirmed on Windows XP/Vista.

Works: 2006032512
Fails: 2006032521

Regression window is:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-03-25+11%3A00&maxdate=2006-03-25+22%3A00

With as the most likely cause: Bug 330863.
Blocks: 330863
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Yep.  Looks invalid to me, per that bug, since the default pref value is to use the user's UI direction.

I should note that the page is abusing "direction" in this case, since that element does not in fact contain RTL content...
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.