Allow start mail check to be customized

RESOLVED FIXED in seamonkey2.0b1

Status

SeaMonkey
MailNews: General
--
enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Peter Brown, Assigned: InvisibleSmiley)

Tracking

(Depends on: 1 bug, {polish})

Trunk
seamonkey2.0b1
polish
Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0a2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1a2pre) Gecko/2008080611 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1a2pre) Gecko/2008080611 SeaMonkey/2.0a1pre

There is not a setting to prevent this.

The setting that does prevent this happening is the setting in the Mail/News client, Server settings, Check for new messages at startup.

In previous Seamonkey versions (v118 backwards) this controlled whether email was checked when Mail/News client was started.


Could you Please revert back to the previous use of this setting: 

I do NOT want to check email every time I start Seamonkey

I DO want to check email when I open the Mail/News client


Maybe it is me but I see no point in checking for email when starting a browser...

Reproducible: Always

Steps to Reproduce:
1. start Seamonkey with the MAIL/NEWS setting "Check for new messages at startup" active
2. when Seamonkey browser loads the check for new email happens
3. uncheck the setting and no automatic check happens at startup or when opening Mail/News window
Actual Results:  
as above

Expected Results:  
with the setting checked I expect the browser startup to IGNORE anything to do with email

the email check should occur when the Mail/News window is opened - if the setting is checked

Please revert to sensible behaviour as shown by the Seamonkey versions prior to v2.0a1pre
This is an enhancement request.
Severity: normal → enhancement

Comment 2

9 years ago
I noticed this recently, too, but for the most part I like the new behavior. Perhaps it could be enhanced by making this a per-account option. For example, I have a POP account that I'd like to know whether there's new mail as soon as I start the browser, but on my IMAP account I'd really prefer not to get an alert when the browser starts.
I think the new summary is more what the issue is now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Starting Seamonkey causes an UNWANTED email check to occur. → Allow start mail check to be customized

Comment 4

9 years ago
Not OS/2 specific.
OS: OS/2 → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 5

9 years ago
This could be considered as "an enhancement request" but I think of it as a request to revert to previous (sensible) Seamonkey behaviour.

As some peple seem to like the new behaviour maybe the option should be changed. Maybe the option should consist of 2 lines:-

Get email at Seamonkey Startup
or
Get email at Mail/News window open

Obviously you should be able to check either option or no option - but not both.


If we are going to get stuck with the current option then I will have to look at reverting to Seamonkey v1.1.n

(Reporter)

Comment 6

9 years ago
Just installed Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1a2pre) Gecko/20080815231110 SeaMonkey/2.0a1pre

This has an interesting variation on the get email theme:

If get email at startup is checked then when the browser starts the email is checked

Guess what happens if I then open the Mail/news window? - the email gets checked.


All we now need is an option to select whether email gets checked at (browser) startup or when the Mail/News window gets opened - Please.

Comment 7

9 years ago
From what I hear this annoys quite a few nightly testers, so I'm requesting blocking.
Flags: blocking-seamonkey2.0a2?

Comment 8

9 years ago
Not blocking an alpha for this.
Flags: blocking-seamonkey2.0a2? → blocking-seamonkey2.0a2-
(Reporter)

Comment 9

9 years ago
I have no idea what "blocking" actually means but it would be nice if the buggy behaviour was rectified as soon as possible.

Should Seamonkey2.0 end up with a Release where email is checked at startup by the Browser then  I can ether uncheck that option or use a different browser - something that behaves as a browser would be my choice.

Should Seamonkey2.0 end up with a Release where email is checked at startup by the Browser then checked again by the email client when the email client window gets opened to look at what email the browser just checked I certainly will not bother with this suite.

Sorry, but I think the original check email at *email* startup actually makes a lot more sense than the current mess. 

As it seems there are some people who are happy to have the *browser* check email at startup it seems the only way of keeping both groups of users happy would be to hook up the existing (buggy?) code to a choice of get email options - either at browser startup or at email startup.

The current mess certainly needs fixing though however you look at it.

Updated

8 years ago
Depends on: 71105
Flags: wanted-seamonkey2?
Keywords: polish

Updated

8 years ago
Depends on: 455252
(Assignee)

Comment 10

8 years ago
Created attachment 376630 [details] [diff] [review]
add checkbox to M&N pane

I think we can consider this bug the last part of bug 71105 and close that one.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #376630 - Flags: superreview?(neil)
Attachment #376630 - Flags: review?(neil)
Comment on attachment 376630 [details] [diff] [review]
add checkbox to M&N pane

I'm not convinced by the wording. Any suggestions?
Attachment #376630 - Flags: review?(neil) → review?(mnyromyr)

Comment 12

8 years ago
"Check mail on startup without opening mail window" ?

Not quite accurate either, but should be close to what it's doing.
More details could be given in the Help information.

Comment 13

8 years ago
"Check for mail on opening a window of any type"?
"Don't check for mail until the main mail window is opened"?

"Wait until the main mail window is opened before checking for new mail"?

Comment 15

8 years ago
(comment #14) This would require "inverted=true" for the preference, but in this case the negative logic may be easier to understand than trying to find an exact match for the positive phrase.
Comment on attachment 376630 [details] [diff] [review]
add checkbox to M&N pane

>+<!ENTITY mailBiffOnNewWindow.label        "Check mail when opening new (e.g. browser) windows">

I wouldn't stress the browser case. How about: 
"Check mail when opening any new &brandShortName; window"?
(Assignee)

Comment 17

8 years ago
(In reply to comment #15)
> (comment #14) This would require "inverted=true" for the preference, but in
> this case the negative logic may be easier to understand than trying to find an
> exact match for the positive phrase.

I also like the idea of describing the opposite (with the inverted pref attribute of course) but I'd use a positive expression without "wait" and with the MailNews window name:
"Only check for new mail when opening Mail & Newsgroups"?
(Reporter)

Comment 18

8 years ago
"Only check for new mail when opening Mail & Newsgroups" looks good to me.

Comment 19

8 years ago
Despite bug 490170, mail would still be checked periodically if set to do so even after closing the mail window, thus the following may be less absolute:

"Only check for new mail after opening Mail & Newsgroups"
(Assignee)

Comment 20

8 years ago
Created attachment 377963 [details] [diff] [review]
checkbox to M&N pane v2
[Checkin: Comment 21]

(In reply to comment #19)
> Despite bug 490170, mail would still be checked periodically if set to do so
> even after closing the mail window, thus the following may be less absolute:
> 
> "Only check for new mail after opening Mail & Newsgroups"

Sounds reasonable to me. Requesting r+sr from Neil since he and Karsten accepted comment 17 on IRC.

BTW in case anyone wonders the functionality switched by this pref currently doesn't work for IMAP; I just filed bug 493478 for that.
Attachment #376630 - Attachment is obsolete: true
Attachment #377963 - Flags: superreview?(neil)
Attachment #377963 - Flags: review?(neil)
Attachment #376630 - Flags: superreview?(neil)
Attachment #376630 - Flags: review?(mnyromyr)

Updated

8 years ago
Attachment #377963 - Flags: superreview?(neil)
Attachment #377963 - Flags: superreview+
Attachment #377963 - Flags: review?(neil)
Attachment #377963 - Flags: review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Comment on attachment 377963 [details] [diff] [review]
checkbox to M&N pane v2
[Checkin: Comment 21]


http://hg.mozilla.org/comm-central/rev/2a92848ff1f9
Attachment #377963 - Attachment description: checkbox to M&N pane v2 → checkbox to M&N pane v2 [Checkin: Comment 21]
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: wanted-seamonkey2?
Keywords: checkin-needed
QA Contact: mail
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
You need to log in before you can comment on or make changes to this bug.