If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Voters email addresses exposed to spam bots

RESOLVED DUPLICATE of bug 163551

Status

()

Bugzilla
User Interface
RESOLVED DUPLICATE of bug 163551
9 years ago
9 years ago

People

(Reporter: Philippe Duchenne, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-0.1 Firefox/3.0.1
Build Identifier: Bugzilla version 3.0

When following the "show votes" links, the voters email addresses are diplayed in clear to any visitors, thus exposing them to spam bots.


Reproducible: Always

Steps to Reproduce:
1. Log out if you are logged
2. Click on any "show" link (for votes)
3.
Actual Results:  
The voters full emails are displayed in clear and "sniffable".


Expected Results:  
Only the name should be shown (without the @ domain) to non-logged users.


Similar (but more general) bug report is bug 219021 ("Email addresses should only be displayed to logged in users").

Comment 1

9 years ago
This bug is not different from the many we already have about this topic. Marking it as a dupe of bug 163551 which is exactly what you are requesting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 163551
You need to log in before you can comment on or make changes to this bug.