JavaScript links don't work with functioncode in an extern file

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Stefan Seifert, Assigned: Warren Harris)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000705
BuildID:
2000070508

When trying to
use a link in the menu that is "javascript:Go2Link(0);" Mozilla goes to an
URL
"javascript:Go2Link(0);" instead of starting the function. The code for the
function is in an extern file
menuf.js. The whole menu doesn't work. It did till
post-M16 nightlies.

Reproducible: Always
Steps to Reproduce:
1.Go to
http://www.detonation.org
2.Try to use the menu on the left side


Actual
Results:  Mozilla goes to URL: javascript:Go2Link(x);

Expected Results:  Load the
function Go2Link(x);
and go to the apropriate URL

Comment 1

18 years ago
Dupe

*** This bug has been marked as a duplicate of 45036 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
*** Bug 45036 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
have already marked 40536 as a duplicate of this...sorry for inconveniences.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

18 years ago
The links under the left-hand menu are JavaScript URLs. For example: 

                      javascript:Go2Link(0)

Currently, JavaScript URLs are not working.... Reassigning to Networking 
for disposition - is this a dup of, say, bug 41707?
Assignee: rogerl → gagan
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Networking
Ever confirmed: true
QA Contact: pschwartau → tever

Comment 5

18 years ago
javascript urls should be working ok. but this seems like a JS problem to me. 
Assignee: gagan → rogerl
Component: Networking → Javascript Engine
QA Contact: tever → pschwartau

Comment 6

18 years ago
JavaScript URLs are still broken; I have reopened bug 41707.

This is not an Engine problem; reassigning to Warren for advice
on where to send this one - thank you.
Assignee: rogerl → warren
Component: Javascript Engine → Embedding: Docshell
(Reporter)

Comment 7

18 years ago
The menu works now on Build 2000071208  Win98SE.

Comment 8

18 years ago
The menu also works for me now. Marking WORKSFORME.
Using Mozilla tip builds 2000-07-12 1PM PDT on WinNT, Linux.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Verified Win98 2000092808
You need to log in before you can comment on or make changes to this bug.