JavaScript links don't work with functioncode in an extern file

VERIFIED DUPLICATE of bug 45035

Status

()

Core
JavaScript Engine
P3
major
VERIFIED DUPLICATE of bug 45035
18 years ago
16 years ago

People

(Reporter: Stefan Seifert, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000705
BuildID:
2000070508

When trying to
use a link in the menu that is "javascript:Go2Link(0);" Mozilla goes to an
URL
"javascript:Go2Link(0);" instead of starting the function. The code for the
function is in an extern file
menuf.js. The whole menu doesn't work. It did till
post-M16 nightlies.

Reproducible: Always
Steps to Reproduce:
1.Go to
http://www.detonation.org
2.Try to use the menu on the left side


Actual
Results:  Mozilla goes to URL: javascript:Go2Link(x);

Expected Results:  Load the
function Go2Link(x);
and go to the apropriate URL

Comment 1

18 years ago
*** Bug 45035 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 45035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.