new Yahoo Mail layout crashes FF3

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: George, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061517 Red Hat/3.0-2.el5 (CK-IBM) (CK-IBM) Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061517 Red Hat/3.0-2.el5 (CK-IBM) (CK-IBM) Firefox/3.0

The new Yahoo mail layout crashes FF3 but not FF 2.0.0.14 on RHEL 5.2.

Reproducible: Always

Steps to Reproduce:
1. firefox http://mail.yahoo.com/
2. login
3. click on mail icon
Actual Results:  
FF3 closes

Comment 1

10 years ago
I too am experiencing problems with the Linux/UNIX versions of Firefox 3.0 crashing on certain advanced web sites.  I am currently not at my Sun Ray using Solaris 10 on the server, but I do have the crash messages:

---

The program 'Gecko' received an X Window System error.  This probably reflects a bug in the program.  The error was 'BadGC (invalid GC parameter)'.  (Details: serial 579794 error_code 13 request_code 60 minor_code 0)

(Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it.  To debug your program, run it with the --sync command line option to change this behavior.  You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)

---

I am not a developer, so I would not know how to properly debug this issue.  If any dev needs more info from me, just let me know what specifically you need, and I will post it here.
(Reporter)

Comment 2

10 years ago
I have no stderr output or core file.

Comment 3

10 years ago
Mozilla/5.0 (X11; U; SunOS sun4v; en-US; rv:1.9) Gecko/2008063022 Firefox/3.0

I think I only had Firefox 3.0 generate a core file once out of all the times it has crashed on me.  I can provide it if necessary.

If you believe that your error and my own are 2 separate errors, then I may need to find out if my error is listed elsewhere.

I have had the following web sites cause Firefox 3.0 for Solaris crash on me:
http://lifehacker.com/
http://arstechnica.com/
http://www.weather.com/

Now it is possible that it could be ads from those sites that cause my browser to crash because Firefox does not crash every single time at those sites, but it is a bug nonetheless.

Comment 4

9 years ago
Firefox 3.0.4 works fine but layout is bad

Comment 5

8 years ago
This bug report seems to conflate a whole bunch of issues :(

If any of you are still hitting crashes after updating to Firefox 3.5 or higher, please file new bug reports with stack traces:

https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.