Firefox freezes when History Menu or sidebar is opened

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Trish Ang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Anytime I click on the 'History' menu on the menu bar, or try to open the History sidebar, I get the colorful spinning wheel of death. The browser immediately freezes, and I can't click anywhere on the window or even on the Apple menu. It even locks up my dock menu thing (i.e. I can't force quit by holding down the mouse on the 'Mozilla' icon). In order to force quit it, I have to click onto another open application, wait a while for it to switch, then go to the force quit menu directly from the Apple menu. 

It sucks, because my immediate instinct anytime I accidentally close a tab I'd been using is to go to History > Recently Closed Tabs. It works fine in FF2 on my machine also, only breaks with FF3, and has been this way since I installed it on Download Day. 

Reproducible: Always

Steps to Reproduce:
1. Click on History menu, from anywhere.
2.
3.
Actual Results:  
Mac spinning wheel of death.

Expected Results:  
Opened the History drop down menu.

I don't use any themes, but I am using the Firefox profile manager to run FF2 and FF3 simultaneously.
Reporter: Can you please list any extensions you have installed in the 3.0.1 profile? What happens if you are not running Firefox 2 at the same time - does it still freeze?
Summary: Firefox crashes when History Menu or sidebar is opened → Firefox freezes when History Menu or sidebar is opened
(Reporter)

Comment 2

10 years ago
Sure thing:

- Download Statusbar 0.9.6.3
- Firebug 1.2.0b7
- Foxmarks 2.1.0.12
- PicLens 1.7.1.3900
- Stylish 0.5.7
- Web Developer 1.1.6

And yes, it still freezes when Firefox 2 is closed.

Comment 3

10 years ago
how big is your places.sqlite file?
(Reporter)

Comment 4

10 years ago
where is that file located? I found places.xpt and it was 12kb

Comment 5

10 years ago
in your profile folder:
http://kb.mozillazine.org/Profile_folder_-_Firefox
(Reporter)

Comment 6

10 years ago
ah thanks!

i have two profiles, one is 14.7 mb, the other is 1.6 mb.

Comment 7

10 years ago
okay, probably unrelated then.  i get a freeze when i open the history menu or sidebar as well, but i know it's because my places.sqlite file is huge (about 100 mb).

just to make sure, though, you could try renaming yours to something else and see if the problem goes away.
(Reporter)

Comment 8

10 years ago
wow, actually, that completely fixed it for me! thanks a lot!

Comment 9

10 years ago
i'm glad i could help you out.
WFM per comment 8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.