If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[NewsFox Extension] Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Administration
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008081217 Minefield/3.0.2pre

Steps to reproduce:
-> Install the NewsFox Extension
-> Start Firefox with this Extension installed
-->  Error: uncaught exception: [Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIRDFService.GetDataSource]"  nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :: chrome://newsfox/content/livemarks.js :: anonymous :: line 148"  data: no]

Comment 1

9 years ago
I think this happened because NewsFox was unable to determine the userAgent and thought Minefield was Firefox 2 or less(hence the rdf bookmarks).  [Not using nightlies so can't tell.]

This is fixed in 1.0.4beta1 at http://newsfox.mozdev.org/installation.html#beta.

Comment: It would never have happened if Minefield set general.useragent.extra.firefox to 'Minefield/x.x.x Firefox/3.x.x' similar to Flock's 'Firefox/x.x.x Flock/x.x.x'.
(Reporter)

Comment 2

9 years ago
Closing as invalid (no Firefox Bug) also per comment #1 fixed in 1.0.4beta1 of the Extension.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.