If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

initial FTP url downloads the data twice.

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
UI Design
P4
normal
VERIFIED FIXED
18 years ago
6 years ago

People

(Reporter: Judson Valeski, Assigned: dougt)

Tracking

({perf})

Trunk
mozilla0.9
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 0.9 needs review, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
visit that url w/ a breakpoint in nsFTPChannel::AsyncRead() and watch it get 
loaded twice, once from the browser and once from xul.

Comment 1

17 years ago
gagan, nominating nsbeta2
Assignee: don → gagan
Keywords: nsbeta2

Comment 2

17 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]

Comment 3

17 years ago
is this networking?
(Reporter)

Comment 4

17 years ago
no. as I pointed out, Asyncread is being called from the browser and once from 
xul.

Comment 5

17 years ago
mcafee someone in don's group needs to take this. so if you are triaging his 
bugs reassign. 
Assignee: gagan → don

Comment 6

17 years ago
bill's been Mr. FTP lately.. over to him
Assignee: don → law

Comment 7

17 years ago
Probably a derivative of the "unknown content cancels channel" problem (which I 
still have a bug on; this one could maybe be closed as a dup).

Things are in a bit of flux at the moment.  mscott added code to intercept 
unhandled (but "known") content *inline* (i.e., without cancelling) in order to 
launch helper apps.  We plan to do likewise with unhandled *and* "unknown" 
content (content with no helper app identified yet).

That would fix this once and for all.  Not till beta3 though, so I'm targetting 
this one out a bit.
Status: NEW → ASSIGNED
Target Milestone: --- → M20

Comment 8

17 years ago
nav triage team:
nsbeta3+
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Keywords: nsbeta3

Updated

17 years ago
Priority: P3 → P2
Whiteboard: [nsbeta2-][nsbeta3+] → [nsbeta2-][nsbeta3+][medium]

Updated

17 years ago
Blocks: 47203

Comment 10

17 years ago
PDT looking at P2 bugs, and we don't understand what bad thing happens -- we
download stuff with FTP all the time, and it only seems to download once.
Whiteboard: [nsbeta2-][nsbeta3+][medium] → [nsbeta2-][nsbeta3+][medium][need info]
(Reporter)

Comment 11

17 years ago
if you view the FTP trace logs, it's downloading twice.

Comment 12

17 years ago
PDT believes p3.  Resetting priority.
Priority: P2 → P3
Whiteboard: [nsbeta2-][nsbeta3+][medium][need info] → [nsbeta2-][nsbeta3+][medium][pdtp3]

Comment 13

17 years ago
Nav triage team: We have to minus this now (minusing everything that's not P1 or 
P2); if this is wrong someone please alert us by removing the [nsbeta3-] from 
status whiteboard.
Whiteboard: [nsbeta2-][nsbeta3+][medium][pdtp3] → [nsbeta2-][nsbeta3-][medium][pdtp3][cut 0919]

Comment 14

17 years ago
Cleaning out status whiteboard and old keywords; adding new nsbeta1 keyword to
nominate this as yet another of the bugs related to
unknown-content/file-download.  I think this one might be fixed.
Keywords: nsbeta2, nsbeta3 → nsbeta1
Whiteboard: [nsbeta2-][nsbeta3-][medium][pdtp3][cut 0919]
taking for qa...
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh

Comment 16

17 years ago
nav triage team:

Marking nsbeta1+
Whiteboard: nsbeta1+

Comment 17

17 years ago
nav triage team:

Putting on the backburner. Yeah, would be nice to have, but won't get to it for
now. Removing nsbeta1+, marking future and p4
Priority: P3 → P4
Whiteboard: nsbeta1+
Target Milestone: --- → Future
(Assignee)

Comment 18

17 years ago
Bill, I though that you were cleaning this up?  Should this really be futured?!
Target Milestone: Future → ---

Comment 19

17 years ago
Pay no attention to the man behind the curain!  This is fixed implicitly by
virtue of bug 28584 (all other cases have already been fixed).

Comment 20

17 years ago
I voted to keep this, lost the vote.  Hope law's got that balloon
ready to take off.  Which way to Kansas!?

Comment 21

17 years ago
nav triage team:

Marking nsbeta1-, not a beta stopper
Keywords: nsbeta1 → nsbeta1-

Comment 22

17 years ago
*** Bug 75320 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
Clearing nsbeta1- for re-evaluation, and adding perf keyword.

Fixing this would _halve_ the time taken to display the initial ftp (and gopher)
url, because the ftp control connection appears to be set up again for the
second time. It is the second loading which causes data to be displayed, and the
second loading doesn't start until just before the first one is finished. See
bug 75320 for NSPR logs.

Bug 28584 is mentioned as fixing this, but that doesn't seem relevent.
Keywords: nsbeta1- → nsbeta1, perf
(Assignee)

Comment 24

17 years ago
I will fix this for 0.9
Target Milestone: --- → mozilla0.9
->dougt, then. :)
Assignee: law → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 26

17 years ago
this is alot of work.  pushing out milestone.... sorry. 
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 27

17 years ago
C8 H10 N4 O2

Not that much work.  I have a patch.
(Assignee)

Comment 28

17 years ago
Created attachment 31325 [details] [diff] [review]
Fixes FTP double loading inital directory listing.
(Assignee)

Comment 29

17 years ago
maybe we can get this into 0.9?

Bradley, please review.
Chris, please give me some sr props.
Keywords: patch
Whiteboard: needs review
Target Milestone: mozilla0.9.1 → mozilla0.9
(Assignee)

Comment 30

17 years ago
*** Bug 76276 has been marked as a duplicate of this bug. ***

Comment 31

17 years ago
nsCOMPtr<nsIChannel> channel = do_QueryInterface(request);
would you consider channel(do_Query...) syntax?
Keywords: approval, review
Whiteboard: needs review → 0.9 needs review
(Assignee)

Comment 32

17 years ago
Created attachment 31329 [details] [diff] [review]
Same patch, but with timeless's suggestion

Comment 33

17 years ago
r=bbaetz on the updated patch (not that I hated the previous one... :-)

Comment 34

17 years ago
waterson has sr'ed
a=drivers

lets get his in if its ready to go.
(Assignee)

Comment 35

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
QA Contact: sairuh → tever

Comment 36

17 years ago
VERIFIED:
I'm using Mozilla 0.9 allplats, in w/ the directory (tree) viewer, and I'm not
getting double requests.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.