Provide an option to run an external application after pressing the restart button (because of a downloaded update) to run a backup program/script

RESOLVED WONTFIX

Status

()

Toolkit
Application Update
--
enhancement
RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Please provide an option to run an external application after pressing the restart button (because of a downloaded update) to run a backup program/script.
Seems like an extreme edgecase for most users... why would we want to add more complexity to app update for this type of convenience for a very small number of users?
Are nightly users so small? On sunday, the calendar nightlies had a bad patch which was backed out and so I had export all my calendars, delete the storage.sdb file and recreate the calendars and import them again. Because Firefox, Thunderbird and Sunbird are nearly open all the time, scheduled backup programs on Windows don't get access to all files. With a few backups in hand, restoring from a nightly regression would be much easier.
(In reply to comment #2)
> Are nightly users so small?
They actually are in comparison to the number of release users... please keep in mind I'm not stating that the nightly users aren't important... just that adding complexity for a small number of users that can already manually or with the appropriate utilities installed can already accomplish this is a risk to the much larger number of users that wouldn't use this functionality.

> On sunday, the calendar nightlies had a bad patch
> which was backed out and so I had export all my calendars, delete the
> storage.sdb file and recreate the calendars and import them again.
How often has something like this happened to you?

> Because
> Firefox, Thunderbird and Sunbird are nearly open all the time, scheduled backup
> programs on Windows don't get access to all files.
There are backup utilities that handle open files and the backup can be done manually by exiting.

> With a few backups in hand,
> restoring from a nightly regression would be much easier.
Understood
(In reply to comment #3)
> > On sunday, the calendar nightlies had a bad patch
> > which was backed out and so I had export all my calendars, delete the
> > storage.sdb file and recreate the calendars and import them again.
> How often has something like this happened to you?
Once to three times per year, I guess (with Firefox and Calendar, don't know how often this happens with Thunderbird).
There haven't been any other people wanting this and with the main audience being nightly users the additional complexity to add this isn't worth it. Resolving -> wontfix.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.