Decimal point is dropped if first character of email body.

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Bobby Gaylor, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080708)

If a user writes and email starting with a decimal point, the decimal point is dropped. This becomes a problem in our planning and estimating department. 
Examples:
".5 inch brass tubing" will turn into "5 inch brass tubing"


Reproducible: Always

Steps to Reproduce:
1. Click write (new email)
2. type ".5 inch brass tubing"
3. Email the message to yourself
4. Click Get Mail
5. Read the mail and see that it says "5 inch brass tubing" instead of ".5 inch brass tubing".
Actual Results:  
The same thing that I explained in steps to reproduce field.

Expected Results:  
Actually kept the decimal point.
There are actually three possible points of failure here.

Please provide an SMTP log when you send a message to yourself (and sanitize it too!): <http://wiki.mozilla.org/MailNews:Logging>
Whiteboard: dupeme
(Reporter)

Comment 2

10 years ago
Created attachment 334275 [details]
SMPT Log of sending the message to myself.

A request was made by Joshua Cranmer to send in an smtp log after I sent a problem message to myself. I have attached the file smpt.log that should contain only data pertaining to the topic email.

Comment 3

10 years ago
I'm not able to reproduce this problem in plaintext or html on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081023 Shredder/3.0b1pre ID:20081023150255
(Reporter)

Comment 4

10 years ago
I apologize. Type the "0.5 inch brass tubing" without the quotes. Really all you need to re-produce the bug is start an email with a decimal/period. It will throw it away so .5 becomes 5
Version: unspecified → 2.0

Comment 5

9 years ago
I'm not able to reproduce this problem in plaintext on Postfix SMTP with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090303 Shredder/3.0b3pre ID:20090303031908

Bobby: Could you test if the problem still persist in Thunderbird 3 beta2?
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads/
I can reproduce either with latest shredder. Resolving as WFM. Reporter please attach such email if you still have the issue with Thnderbird 3.0 beta2 (http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads/)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Composition
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Resolution: --- → WORKSFORME
Whiteboard: dupeme
Version: 2.0 → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.