When right click on email address, add option to open existing contact in address book

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: bob.schumm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080708)

Current choices are to
 - Add to address book
 - Compose mail to
 - Copy email address

It would be very helpful to offer a search of the address books, and if found, to open the contact window in the address book.

This would allow a user to correct contact info (such as a new phone number, etc) that appears in the sender's email signature without having to do a manual search of the contact.

Frequently, I would like to update a contact's information, or look-up details of a contact that is on an email chain.  Being able to right-click on the email address in the message header of the preview pane and launch the contact would be a welcome change.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
If the contact is in the address book, then open the properties window for the given contact (the first instance in case of duplicates).

If the contact is not found, either don't open or open a new contact screen.


It would also be great if the fact that the sender was in your address book was marked (like the SPAM marker) in the message list view.  This would let you determine if a sender was known (you already have their address) or unknown.
No LDAP search should be performed as what is relevant is whether YOU know the sender, not the LDAP's organization.
This has been fixed by bug bug 450724 attachment 336332 [details] [diff] [review].
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 454045
You need to log in before you can comment on or make changes to this bug.