If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clear private data: no way to clear font size preference for sites

RESOLVED DUPLICATE of bug 380852

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 380852
9 years ago
9 years ago

People

(Reporter: teoli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr-FR; rv:1.9.1a2pre) Gecko/20080815020705 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr-FR; rv:1.9.1a2pre) Gecko/20080815020705 Minefield/3.1a2pre

There is no way through Clear Private Data to clear stored site-specific font-size. This is a minor privacy issue as it allows to discover some visited sites.

Reproducible: Always

Steps to Reproduce:
1. Go to any site
2. Set the font huge
3. Close the site
4. Tools > Clear Private Data with all options set
5. Restart firefox
6. Go back to the same site
Actual Results:  
Huge font for the site

Expected Results:  
Standard font size of the site

This is a minor privacy issue as it allows to get some partial information about the sites visited after a Clear Private Data.

Proposal: hook the site-specific font size to 'Offline website data' in Clear Private Data.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380852
You need to log in before you can comment on or make changes to this bug.