background-color in usercontent.css ignored

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: 0mark, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Firefox ignores every background-color setting in the userContent.css, at least for every form element. Even with !important the background color is only changed if the element has a background color already set.
Changing the border also doesnt work.
Other settings, like color or font-size, works like expected.
Setting a background color for everything (*) changes the background color fpr everything, except form elements.

Reproducible: Always

Steps to Reproduce:
0. use a dark colored gtk theme and no firefox theme
1. edit chrome/userContent.css like this:
input { background-color: white; color: black; }
2. open any website with form elements with unset background, like this:
<html>
  <head><title>test</title></head>
  <body>
    <form method="get" action="get.php">
      <input id="query" name="q" size="10" value="" type="text">
    </form>
  </body>
</html>
Actual Results:  
The input field has no white background (except if with the choosen theme the background will be white by default ;)

Expected Results:  
The input field should have a white background.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
I think this is a duplicate of Bug 419973.

Comment 2

10 years ago
For this to work, you
1. need to use !important
2. more importantly, you need to specify '-moz-appearance:none;'.

So this is by design. See bug 240117 comment 18 and down.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> For this to work, you
> 1. need to use !important
>
> 2. more importantly, you need to specify '-moz-appearance:none;'.
> 
> So this is by design. See bug 240117 comment 18 and down.
> 
Do you mean there is no way to override the default but not the site styles? If this is so by design, then i dont like the design ;)

(In reply to comment #1)
> I think this is a duplicate of Bug 419973.
I think not. When normaly using css in a site it all works for me, but the same setting in chrome/userContent.css is ignored.
(Reporter)

Comment 4

10 years ago
So, im Sorry. 
Its realy not a Bug. As philippe said, '-moz-appearance:none;' fixed the problem. At least i had searched the web for a solution, but i failed ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Duplicate of this bug: 452291
You need to log in before you can comment on or make changes to this bug.