Drag & drop of image from some webpages (i.e Discogs) corrupts and/or distorts image.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Pär Halleröd, Unassigned)

Tracking

({dataloss})

3.0 Branch
x86
Windows Vista
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

If you drag & drop album cover from discogs into explorer window, the resulting image file is corrupted. Right click - Save Image As still works flawlessly. Only drag and drop behavior is affected.

Reproducible: Always

Steps to Reproduce:
1. Take any Discogs album cover page. I.e: http://www.discogs.com/viewimages?release=1219668
2. Open any folder in Explorer
3. Drag and drop Image to folder
Actual Results:  
The image is corrupted and/or distorted

Expected Results:  
The image should be an exact copy of image displayed in browser

The problem was also existing in Firefox 2, only then you got an error dialog box.
https://bugzilla.mozilla.org/show_bug.cgi?id=371702
(Reporter)

Updated

9 years ago
Keywords: dataloss
Version: unspecified → 3.0 Branch
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.