bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Use To identity as From in reply

RESOLVED DUPLICATE of bug 327713

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 327713
10 years ago
10 years ago

People

(Reporter: Eric Rosenbloom, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: 2.0.0.16 (20080707)

I have a few mail accounts (personal, business, volunteer org) all forwarding to and using the local folders of one master account.

That means that the From address in any reply is always that master account by default, which I then have to remember to check and change if appropriate.

It would be nice if the From address automatically used the To address (if it is one of my identities) in a reply.

Reproducible: Always

Steps to Reproduce:
1. Receive a message addressed to eric@account2 forwarded to eric@account1.
2. Reply: the From field is eric@account1.
3. Change From field to eric@account2.


Expected Results:  
Desired change: Reply automatically sets From field to eric@account2.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
That's how it works, you just have to set up those e-mails as identities for the account. (I assume you mean they all forward to the one account server side somehow.)
(Reporter)

Comment 2

10 years ago
Yes, to clarify, all the accounts forward at their various servers to one of my addresses, so that in Thunderbird, I'm working out of only 1 account. All the other accounts (and identities) are of course set up in Thunderbird and used for outgoing mail.

So it would be a neat feature, I think, when replying to a message, to check if the To field of the original message is one of my identities, and if so use it in the From field of the reply.

Comment 3

10 years ago
Ah yes, bug 327713.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327713
You need to log in before you can comment on or make changes to this bug.