Closed Bug 450889 Opened 13 years ago Closed 13 years ago

FreeBSD Build Error: expected specifier-qualifier-list before 'semaphore'

Categories

(Core :: Audio/Video, defect)

x86
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 449066

People

(Reporter: pi, Unassigned)

Details

When trying to build Thunderbird or Firefox from trunk in FreeBSD, I get the following error:

In file included from /usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c:40:
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay_private.h:105: error: expected specifier-qualifier-list before 'semaphore'
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c: In function 'oggplay_prepare_for_close':
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c:617: warning: implicit declaration of function 'SEM_SIGNAL'
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c:617: error: 'OggPlayBuffer' has no member named 'frame_sem'
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c: In function 'oggplay_get_available':
/usr/home/josh/comm-central/mozilla/media/liboggplay/src/liboggplay/oggplay.c:631: warning: implicit declaration of function 'oggz_tell'
FWIW, this looks like someone only did a Linux-Windows-Mac switch in mozilla/media/liboggplay/src/liboggplay/std_semaphore.h. semaphore.h appears to be a POSIX header.
Bug 449066 has a patch to get things working on FreeBSD. 
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449066
You need to log in before you can comment on or make changes to this bug.