Move IMAP folders fail on third+ try

RESOLVED DUPLICATE of bug 448550

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 448550
10 years ago
10 years ago

People

(Reporter: Morten Gade Sørensen, Assigned: Bienvenu)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_4; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080816032316 Shredder/3.0b1pre

When moving (IMAP) folders from one place to another within the same mailbox it only succeeds the first two times. Subsequent tries seems to just be ignored (status bar does not update and the folder is not moved). When restarting Shredder (Thunderbird) I can move two more folders successfully but the 3rd+ tries will fail. Error Console is blank.

Reproducible: Always

Steps to Reproduce:
1. Start Shredder having an IMAP account configured
2. Create a subfolder called First
3. Create a subfolder called Second
4. Create a subfolder called Third
5. Create a subfolder called Parent
6. Move First to Parent. Will successfully be moved
7. Move Second to Parent. Will successfully be moved
8. Move Third to Parent. This and subsequent moves fail
Actual Results:  
Third and subsequent folder moves fail.

Expected Results:  
Same behaviour as first and second folder move.
Can you provide a protocol log?
<http://wiki.mozilla.org/MailNews:Logging>
Assignee: nobody → bienvenu
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → Core
QA Contact: front-end → networking.imap
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
Created attachment 334125 [details]
IMAP Protocol log

Third folder move try leaves no trail in the log.
(Assignee)

Comment 3

10 years ago
that means we didn't try, which means it's not an imap protocol bug.
Status: UNCONFIRMED → NEW
Component: Networking: IMAP → Backend
Ever confirmed: true
Product: Core → MailNews Core
(Assignee)

Comment 4

10 years ago
perhaps the copy service got stalled.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448550
You need to log in before you can comment on or make changes to this bug.