Extra setting: do not ask when clearing private data on exit

RESOLVED WONTFIX

Status

()

Firefox
Preferences
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Someone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; he; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; he; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Firefox currently allows you to make it not ask you when clearing private data but that happens on any case even when you're clearing your private data from the browser this is kinda inconvenient as you know have to go to the preferences page to do that one time oddball cleanup of saved passwords/cookies/etc...

So what I'm suggesting is the addition of a settings to only not ask you on clearing private data on exit.
So when you clear from inside firefox you still get asked as to what clear.

This will also require another modification as to what settings it will use when clearing on exit as with the current design it will use the setting you have used from the browser which might lead a user forgetting to change it after cleaning to what he wants it to clear on exit.

Reproducible: Always

Comment 1

10 years ago
Confirming this enhancement request.
Status: UNCONFIRMED → NEW
Ever confirmed: true
We dont' have a pref now.  We don't prompt when you set to clear on shutdown, and we always prompt when you call it manually.

WONTFIX as filed, since we're not going to have prefs, period.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

9 years ago
Wait now that im reading this again...

Firefox has 2 prefs: ask me on shutdown and ask me when i clear private data.
When both are checked and you close firefox, it asks you to clear private data.
Which isnt a desired behivor from most people.
Yet unchecking the option ask me when i clear private data.
also makes it not ask you when you clear private data manually which you might want.

This is why i made this bug report from the first place, please try it yourself.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Firefox no longer asks under any circumstance when set to clear reeent history on shutdown.  Please go try Firefox 3.1 Beta 3 before you reopen bugs.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.