When opening draft on IMAP folder from a different computer, mail message is sent with wrong From address

RESOLVED DUPLICATE of bug 394216

Status

--
major
RESOLVED DUPLICATE of bug 394216
10 years ago
8 years ago

People

(Reporter: anthony.geoghegan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: not relevant - ongoing problem over past few years

This is the first bug I've ever had to report. Aside from a brief flirtation with mutt, I've been using Thunderbird / Mozilla Mail / Netscape Communicator for the last 10 years and think it's by far the best mail client out there. However this it is a particularly frustrating bug and the consequences can be serious (see last part of Additional Information).

The problem affects users using multiple identities in Thunderbird to access different IMAP accounts from different computers. When draft mail messages stored on an IMAP account are re-opened on a different computer, the From: address in the headers silently changes without alerting the user.

Reproducible: Always

Steps to Reproduce:
1. Start composing an email using an IMAP identity in TB and save as draft
2. Open TB on a different computer and resume editing the content of the draft email. 
3. Click send.
Actual Results:  
When the user opens the draft, the From: address silently changes to that of the default identity set up in Thunderbird. It's very easy for the user to not actually notice that the From: address has changed in the Message Compose window.  Even if they are aware of the issue, it can still catch them out if they are tired or in a hurry and the message is then sent with the wrong From: address.

Expected Results:  
When Thunderbird opens the draft email, it should retain the From: address and check to see if there is a local identity which corresponds with the From: address as saved in the draft. It shouldn't silently change the identity and From address of the message.

This behaviour occurs when I change between my home computer running GNU/Linux and my work computer running WinXP. It has happened a few times over the past two years and I normally remember to re-check the From address.

I notice from viewing the source of the draft messages, that they contain different identifying fields (eg. X-Identity-Key: id2; X-Identity-Key: id5). I presume when the draft is re-opened, Thunderbird looks at this field rather than the From address and it seems that when it doesn't find a matching ID, it changes the sending identity to be that of the default identity.

The most serious consequence of this bug is that when a draft is re-opened on my work PC and a mail message is sent to a public mailing list, everyone on that mailing list can see my work email address which I would rather keep private.

Comment 1

10 years ago
I can confirm this bug. Additional info if I create a draft using my iphone or webmail the edit as new later using thunderbird works properly. Only if I use a different thunderbird to create the draft initally it fails. 
I think the problem lies in the X-Identity-Key: id3
thunderbird is trying to use that to match up the account, but the id will be different from computer to computer.
Status: UNCONFIRMED → NEW
Ever confirmed: true
DUP of Bug 394216.
I slightly modified bug summary Bug 394216 for ease of understanding of problem.
Please change bug summary of Bug 394216 to appropriate one, for ease of search.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394216
You need to log in before you can comment on or make changes to this bug.