change language for spelling checker not applied to all fields

RESOLVED DUPLICATE of bug 361726

Status

()

Core
Spelling checker
RESOLVED DUPLICATE of bug 361726
10 years ago
9 years ago

People

(Reporter: lode_leroy, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080817002455 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080817002455 SeaMonkey/2.0a1pre

I think that the "current" language for spell-checking fields is not correctly
updated.


Reproducible: Always

Steps to Reproduce:
Lets say I have tow fields in a page, F1 and F2
my "current" language for the page is L1
1.I start typing in F1, in language L2
2.I realize that the spell checker is using the wrong language, so I right click the field, set the language to L2
3.I now start typing in F2, in language L2

Actual Results:  
4.The spelling for this field is L1
5.I right click to change the language, but the selected one is "L2" already!

Expected Results:  
Either the selection is per field, and then the language for the field F2 should show in the context menu as L1,
or the selection is per page, and then the language for the field F2 should be L2

as it is now, there is a mismatch between the language used in the field,
and the indication of the language used in the context menu
Assignee: general → mscott
Severity: minor → normal
Component: General → Spelling checker
Product: SeaMonkey → Core
QA Contact: general → spelling-checker
Version: unspecified → Trunk

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361726
You need to log in before you can comment on or make changes to this bug.