If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xulrunner won't download update if update is marked as minor

RESOLVED DUPLICATE of bug 450251

Status

Toolkit Graveyard
XULRunner
RESOLVED DUPLICATE of bug 450251
9 years ago
2 years ago

People

(Reporter: Łukasz Siudut, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008071718 (Gentoo) Firefox/3.0.1
Build Identifier: 1.9.0.1

Problem occurs when update is marked as minor. Xulrunner is not downloading pointed update, but it creates dir structure (updates/0), and update.status file. Status is marked as downloading.

Reproducible: Always

Steps to Reproduce:
1. Create update.xml, mark update type as "minor", and put it on update server.
2. Set preferences as described on http://developer.mozilla.org/en/docs/XULRunner:Application_Update, change app.update.url to your update server and app.update.interval to 10 seconds.
3. Run application and wait.
Actual Results:  
Update is marked as downloading, but .mar file is not even created, connection is broren with tcp rst flag (sniffed with tcpdump and wireshark).

Expected Results:  
Xulrunner should download file and inform about available update.

I've done some research, and I find out solution. Problem seems to be in nsUpdateService.js file. When DOWNLOAD_BACKGROUND_INTERVAL is set to 600 (default), or even 1, download won't start. But when i set it to 0, xulrunner downloaded file normally and informed me about available update.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450251
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.