test_opener.html fails intermittently with 'Should be able to navigate popup by targeted hyperlink. | got Error: Permission denied to get property Window.document, expected "This frame was navigated."'

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: ted, Assigned: abarth-mozilla)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From the linked tinderbox log:
*** 12916 ERROR FAIL | Should be able to navigate popup by targeted hyperlink. | got Error: Permission denied to get property Window.document, expected "This frame was navigated." | /tests/docshell/test/navigation/test_opener.html
(Assignee)

Comment 1

10 years ago
Probably related to Bug 446197.
Apparently the error message got better, I don't know if this helps you more:
*** 22452 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by targeted hyperlink. - got Error: Permission denied for <http://localhost:8888> to get property Window.document from <http://test1.example.org>., expected "This frame was navigated."

From: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1219236276.1219240177.10175.gz
Duplicate of bug 448537 !?
(In reply to comment #3)
> Duplicate of bug 448537 !?

Based on comment dates:
comment 2 is bug 448537;
comment 0 is this (different) bug;
and bug 446197 has yet a different error.
(Assignee)

Comment 5

10 years ago
I found the race condition by inspecting the code.  It's an but in the tests.  If the intermittent failures are annoying, go ahead and disable them.  I'll prepare a patch when I get back to the US.  (It's the same issue in both test_opener.html and test_not_opener.html if you want to dup the bugs against this one.)
(Assignee)

Updated

10 years ago
Duplicate of this bug: 448537
Adam: awesome! This isn't failing incredibly often, so I'd rather leave it enabled for now.
Assignee: nobody → abarth-mozilla
(Reporter)

Updated

10 years ago
Duplicate of this bug: 446197
This also seems to timeout occasionally, spilling focus errors in its wake:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1219921032.1219925873.12623.gz

*** 23183 INFO Running /tests/docshell/test/navigation/test_opener.html...
*** 23184 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_opener.html | Test timed out.
*** 23186 INFO Running /tests/docshell/test/navigation/test_popup-navigates-children.html...
*** 23187 INFO Error: Unable to restore focus, expect failures and timeouts.

Not sure if this is a symptom of the same problem.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1220900437.1220907272.19130.gz
Linux mozilla-central qm-centos5-moz2-01 dep unit test on 2008/09/08 12:00:37
(Assignee)

Comment 11

10 years ago
I've re-implemented these tests in a way that should be reliable.   See http://trac.webkit.org/changeset/36262

Once I port them to the mochitest framework, we can resolve this bug.
Blocks: 456463
Whiteboard: [orange]
Adam: do you have time to do this, or should we get someone else to fix it?
(Assignee)

Comment 13

10 years ago
This isn't at the top of my list.  If someone else would like to work on this, I'd be happy to answer questions.
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.