Set up surveys.mozilla.org for the Community Surveys Program

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: stas, Assigned: chizu)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080810020855 Minefield/3.1a2pre
Build Identifier: 

Community Surveys Program is run by Seth Bindernagel and Staś Małolepszy. Originally, it was created as Stas' internship project at Mozilla Europe at was aimed at surveying mostly European communities. Hence the current domain: surveys.mozilla-europe.org.

As of now, we support many more, non-European locales and publish our surveys globally to people of many continents. I would like to ask for a subdomain at mozilla.com ,to better reflect this fact.

survey.mozilla.com is taken by the uninstall survey, so I propose surveys.mozilla.com (is it too similar to survey.mozilla.com?). If possible, I would also like to keep the old mozilla-europe.org subdomain as well. Is this doable?

Whose approval do I need for this change?



Reproducible: Always
Are the surveys MoCo-specific? If not, maybe it would make sense to use surveys.mozilla.org?
(Reporter)

Comment 2

9 years ago
No, they're not. I like this idea.

I was intending though on changing the design of the site to follow the fx3 mozilla.com style, and that's why I thought about mozilla.com. 

Would having a *.mozilla.org site with mozilla.com-like design be acceptable?

Comment 3

9 years ago
Most surveys are going to relate to MoCo, but Reed brings up a very good point.  All of the communities are related to our community and that will include non-MoCo projects.  Unless Staś thinks otherwise, I would vote for surveys.mozilla.org.
(Reporter)

Comment 4

9 years ago
If a mozilla.com-like design is OK on a *.mozilla.org site, then I'm all for surveys.mozilla.org. Reed, thanks for the suggestion.

Is it possible to have both surveys.mozilla-europe.org and surveys.mozilla.org operational and pointing to the same site? Or do one of them need to be a redirect?
(In reply to comment #4)
> Is it possible to have both surveys.mozilla-europe.org and surveys.mozilla.org
> operational and pointing to the same site? Or do one of them need to be a
> redirect?

Either way is fine. We can support both, as long as the webapp itself can support being called different names.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

9 years ago
Ok, great! 

So what is the next step now? Do I need an approval for this?
(In reply to comment #6)
> So what is the next step now? Do I need an approval for this?

Next step is just for somebody in IT to set it up. You don't need approval.
(Reporter)

Comment 8

9 years ago
OK, so just to sum up:

Please set up a surveys.mozilla.org subdomain pointing to the same directory as surveys.mozilla-europe.org.

Thanks!
(Assignee)

Updated

9 years ago
Assignee: server-ops → thardcastle
(Reporter)

Updated

9 years ago
Blocks: 449417
Blocks: 452510
Summary: Set up new subdomain at mozilla.com for the Community Surveys Program → Set up surveys.mozilla.org for the Community Surveys Program
(Assignee)

Comment 9

9 years ago
surveys.mozilla.org added as part of the existing vhost, is that all that's needed?
Status: NEW → ASSIGNED
(Reporter)

Comment 10

9 years ago
Thanks! 

But - why when I try to access http://surveys.mozilla.org/ am I getting an 'Address not found' error?
(In reply to comment #10)
> Thanks! 
> 
> But - why when I try to access http://surveys.mozilla.org/ am I getting an
> 'Address not found' error?

Does it show up in nslookup?

C:\Users\Owner>nslookup surveys.mozilla.org
<snip>

Non-authoritative answer:
Name:    star-moz-org-php5.nslb.sj.mozilla.org
Address:  63.245.209.79
Aliases:  surveys.mozilla.org

If not, see if you can access it by its raw IP; it might be some Netscaler load-balancing issue you're seeing.
Er, nevermind; raw IP doesn't work, sorry, since it's a vhost.
(Reporter)

Comment 13

9 years ago
It seems to be working OK today :) 

Trevor, Stephen, thanks for your help. Closing this bug now.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified per Staś's comment 13.  (Thanks!)
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.