Last Comment Bug 451139 - The return value of read() function should check in nsRandomAccessInputStream::readline instead of invoking failed().
: The return value of read() function should check in nsRandomAccessInputStream...
Status: RESOLVED FIXED
: fixed1.8.1.18
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla1.9.1b1
Assigned To: Hiroyuki Ikezoe (:hiro)
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 19:59 PDT by Hiroyuki Ikezoe (:hiro)
Modified: 2008-10-20 18:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch [Checkin: Comment 7] (919 bytes, patch)
2008-08-18 20:04 PDT, Hiroyuki Ikezoe (:hiro)
brendan: review+
benjamin: superreview+
dveditz: approval1.8.1.18+
Details | Diff | Splinter Review

Description Hiroyuki Ikezoe (:hiro) 2008-08-18 19:59:55 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15) Gecko/20080702 Ubuntu/8.04 (hardy) Firefox/2.0.0.15 Kazehakase/0.5.4
Build Identifier: 

The return value of read() function should check in nsRandomAccessInputStream::readline.

I guess TB48808062, TB48797096 etc. are caused by this issue.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Hiroyuki Ikezoe (:hiro) 2008-08-18 20:04:02 PDT
Created attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]
Comment 2 Brendan Eich [:brendan] 2008-08-18 22:55:29 PDT
Comment on attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]

Looks good to me but I would be glad if Benjamin could sr+.

/be
Comment 3 Daniel Veditz [:dveditz] 2008-08-20 15:03:49 PDT
Comment on attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]

Please get the requested super-review before requesting approval to land the patch. You can find benjamin on irc.mozilla.org
Comment 4 Hiroyuki Ikezoe (:hiro) 2008-08-25 15:48:42 PDT
Comment on attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]

The patch will raise stability.
Comment 5 Samuel Sidler (old account; do not CC) 2008-08-27 01:49:35 PDT
Comment on attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]

This will have to get looked at in 1.8.1.18. We're frozen.
Comment 6 Daniel Veditz [:dveditz] 2008-09-22 11:25:52 PDT
Comment on attachment 334398 [details] [diff] [review]
Patch
[Checkin: Comment 7]

Approved for 1.8.1.18, a=dveditz for release-drivers
Comment 7 Reed Loden [:reed] (use needinfo?) 2008-09-30 22:06:42 PDT
http://hg.mozilla.org/mozilla-central/rev/1d02d37faf24
Comment 8 Daniel Veditz [:dveditz] 2008-10-20 18:12:50 PDT
Fix checked into the 1.8 branch

Note You need to log in before you can comment on or make changes to this bug.