Borders around folder icons in directory listings (e.g. when viewing FTP sites)

VERIFIED FIXED in mozilla1.9.1a2

Status

()

defect
--
trivial
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: smrank, Assigned: roc)

Tracking

({regression, testcase, verified1.9.1})

Trunk
mozilla1.9.1a2
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080818113442 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080818113442 Minefield/3.1a2pre

When viewing a file:// or ftp:// listing the folder icons now have blue/purple link borders around them.

Reproducible: Always

Steps to Reproduce:
1. Visit the URL.

Actual Results:  
Notice the "pub" folder icon has a blue/purple border around it.


Expected Results:  
The "pub" icon should not have a border around it.


Regression date is the following:
OK: 20080817033619
Bad: 20080818033342
http://hg.mozilla.org/mozilla-central/index.cgi/pushloghtml?startdate=2008-08-17+03%3A36%3A19&enddate=2008-08-18+03%3A33%3A42

The directory listing uses generated content so Bug 238072 seems the most likely candidate. I've put this in networking instead since it seems like that bug may have just exposed a problem with the directory listings rather than being the root cause, sorry if I've got it the wrong way around.
Reporter

Comment 1

11 years ago
Posted file Reduced testcase
This shows the borders on 2008-08-18 but not on 2008-08-17 builds.
Reporter

Updated

11 years ago
Keywords: regression, testcase
Component: Networking → Style System (CSS)
Flags: blocking1.9.1?
QA Contact: networking → style-system
Hmm.  So the thing is, now that we're creating an actual HTML <img> for the url() image, the ua.css for linked images which put borders on them apply.  We want to fix that.
Blocks: 238072
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → Trunk
This fix should be pretty easy, building it now...
Assignee: nobody → roc
Posted patch fix (obsolete) — Splinter Review
Attachment #334539 - Flags: superreview?(bzbarsky)
Attachment #334539 - Flags: review?(bzbarsky)
Attachment #334539 - Flags: superreview?(bzbarsky)
Attachment #334539 - Flags: superreview+
Attachment #334539 - Flags: review?(bzbarsky)
Attachment #334539 - Flags: review+

Comment 5

11 years ago
Don't forget to modify reftest.list when you check in.
Posted patch fix v2Splinter Review
good catch
Attachment #334568 - Flags: superreview+
Attachment #334568 - Flags: review+
But the rule:
  mozgeneratedcontentimage { border: medium solid blue; }
shouldn't apply either.

(I thought we fixed this problem for scrollbars; can't we reuse the same fix?)
> But the rule:
>  mozgeneratedcontentimage { border: medium solid blue; }
> shouldn't apply either.

Even if it's in a UA stylesheet?  Those are the only styles we'll apply to this node.

Note that we do apply UA styles to scrollbars.
Attachment #334539 - Attachment is obsolete: true
Pushed as 17097:4b6e1af7a819 (reftest.list as 17098:012570700797).
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a2
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080820020636 Minefield/3.1a2pre and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080820035100 Minefield/3.1a2pre. I verified using the ftp site.
Status: RESOLVED → VERIFIED
Flags: blocking1.9.1? → blocking1.9.1+
Keywords: fixed1.9.1

Updated

11 years ago
Keywords: verified1.9.1
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.