Posting to form handler more than once causes form to return to main display.

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
major
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: William Stearns, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This is a closed server, so I don't know if you can actually test this.  This is
a compiled perl script program that has mutilple layers and each one is accessed
via form submissions (POST) to the same file.  This program works fine with
Netscape 4.7 and IE 5.5.  And has worked fine in previous versions of Netscape
and IE.  So I assume it is a bug.  It happens everytime, so it's not
intermittent.  The source of the document has all of the appropriate  tags for
the form to submit properly...so...:-)

Comment 1

18 years ago
reassigning
Assignee: rods → pollmann
(Assignee)

Comment 2

18 years ago
This works for me in today's build:

Visited main page.

Selected TW - Wilmington
Selected Burgaw
Clicked Display Report

Report was displayed.

Clicked Reload
Clicked Cancel

This returned me to the main page (Clicking back didn't work apparently because 
of a bug in Session History)

Selected TW - Greensboro
Selected Archdale
Clicked Display Report

Report was displayed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

18 years ago
> This returned me to the main page (Clicking back didn't work apparently
> because of a bug in Session History)

This is bug 32293, which magically appeared on my plate.  :)

Updated

18 years ago
QA Contact: ckritzer → vladimire

Comment 4

18 years ago
Updating QA contact.

Comment 5

17 years ago
Trusting Eric on this.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.