Toolbar buttons and address bar stop working after some use.

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: kannan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Firefox was working fine.  After a couple weeks the following problems occurred:

1. Address bar mostly unresponsive.  I can still type in URLs and have them come up, but:
- Firefox doesn't bring up the autocomplete/history-searching dropdown as I type.
- Displayed URL doesn't update when I click on a URL or switch tabs.

2. Back/forward/refresh/stop buttons are always greyed out.  I can still right-click on the back/forward buttons to select a previous page to navigate to.

-----

The first time I ran into this problem, I
1. Deleted Firefox.app
2. Deleted all the Firefox-related data in my home directory.
3. Reinstalled Firefox

The problem went away.  Then after about a week, it happened again.

(Not sure if step 2 was necessary.  This time, I'll try skipping step 2 and see what happens.)

[Firefox 3.0.1 on Mac OS X 10.4 (PowerPC)]

Reproducible: Sometimes
(Reporter)

Comment 1

10 years ago
Ok, reinstalling Firefox.app had no effect (to be expected, I guess...).  To get things working again, I did:

  rm -r "~/Library/Application Support/Firefox"

This is kind of annoying because I lose my history and preferences.

Just to be clear: this problem comes up in the middle of a browsing session and then persists across restarts of Firefox.
Please try safe-mode to rule out buggy add-ons or try a new profile if this is not enough.
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 3

10 years ago
Ok, will try this the next time the problem comes up.  I probably should have made a copy of the profile folder before deleting it, huh?

If it's any help, my "Add-ons" panel currently shows:
- No extensions.
- One theme: "Default 3.0.1".
- Several plugins for Java, Flash, and QuickTime.
(Reporter)

Comment 4

10 years ago
I tried "-safe-mode".  I checked all the checkboxes in the initial "Firefox Safe Mode" dialog box.  The problem persisted.

I then ran with "-profilemanager", created a profile, and launched the browser.  The problem was gone.  But if I quit the browser and started it again (using the newly-created profile), the problem reappeared.  

I then tried deleting stuff in the "~/Library/Application Support/Firefox" directory.  Deleting "Profiles" just causes Firefox to create a default profile the next time.  Again, the browser works fine but if I restart the problem reappears.  Deleting the "Crash Reports" directory didn't seem to have an effect.  But strangely, deleting the entire "~/Library/Application Support/Firefox" directory worked -- the next time I started Firefox it created a default profile and everything seems to work now.

Is there a debug log I can enable to see if Firefox is choking on something at startup?
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.