Language Options: Esperanto [eo] missing

VERIFIED DUPLICATE of bug 62578

Status

P5
minor
VERIFIED DUPLICATE of bug 62578
18 years ago
14 years ago

People

(Reporter: ed, Assigned: nhottanscp)

Tracking

({intl})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    

In the language selection dialog, the entry for Esperanto (ISO code "eo") is 
missing. Fix should be trivial. If it's relevant, the default charset for 
esperanto is ISO Latin-3 (or UTF).

Reproducible: Always
Steps to Reproduce:
Open preferences. Click on navigator:languages :)

Actual Results:  No entry "Esperanto [eo]".		

Expected Results:  Should be an entry "Esperanto [eo]".
matt/teruko, should this go over to i18n or l10n?
QA Contact: sairuh → teruko

Comment 2

18 years ago
I would kick this to the i18n people

Comment 3

18 years ago
http://www.egt.ie/standards/iso639/iso639-en.html

Is the "Languages for webpages" list supposed to be exhaustive? If so, Esperanto 
isn't the only one missing. If not, when would a language qualify for the list?
(Reporter)

Comment 4

18 years ago
How about at least the languages with a category at http://dmoz.org/World/? :)

Comment 5

18 years ago
confirming this. It's either a bug or an RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
Typing 'eo' in the "others" box will add "Esperanto [eo]" to the 'Languages for
Web Pages' list. So the language code is known to Mozilla, it's just missing
from the selection list for some reason.

Comment 7

18 years ago
Bug 40103 reports that Hebrew is also missing.

Comment 8

18 years ago
Still not in Win32 nightly 20001012. Confirming bug.
Status: NEW → ASSIGNED

Comment 9

18 years ago
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/locale/en-US/lang
uageNames.properties
I think the above file has the list of locals that will magically appear as 
recognized.

For my convenience, because i'm going to attach patches to the other bug, i'm 
marking a dependency. Don't blow it away to be argumentative, but when the fix 
is in you can do whatever you like (if you own the bug).
Depends on: 40103

Updated

18 years ago
Keywords: intl

Updated

18 years ago
Blocks: 62578

Updated

18 years ago
Assignee: matt → ftang
Status: ASSIGNED → NEW

Comment 10

18 years ago
reassign to ftang

Comment 11

18 years ago
I guess change
eo.accept =     false
to
eo.accept =     true
in intl/locale/src/language.properties
will make it appear in the pref.
Can some one try it and confirm it ?

Mark it as P5
Assignee: ftang → nhotta
Priority: P3 → P5
(Assignee)

Comment 12

18 years ago

*** This bug has been marked as a duplicate of 62578 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 13

18 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.