Closed Bug 451334 Opened 12 years ago Closed 11 years ago

"ASSERTION: Creating a circular frame list, this is very bad" with -moz-column, float

Categories

(Core :: Layout, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, hang, testcase)

Attachments

(1 file)

Loading the testcase triggers six assertions and a hang:

###!!! ASSERTION: Float frame has wrong parent: 'floatFrame->GetParent() == mBlock', file /Users/jruderman/central/mozilla/layout/generic/nsBlockReflowState.cpp, line 791

###!!! ASSERTION: Parent not consistent with exepectations: 'aOldParent == aFrame->GetParent()', file /Users/jruderman/central/mozilla/layout/generic/nsBlockFrame.cpp, line 601

###!!! ASSERTION: Out of flow frame doesn't have the expected parent: 'outOfFlowFrame->GetParent() == this', file /Users/jruderman/central/mozilla/layout/generic/nsBlockFrame.cpp, line 6671

###!!! ASSERTION: Parent not consistent with exepectations: 'aOldParent == aFrame->GetParent()', file /Users/jruderman/central/mozilla/layout/generic/nsBlockFrame.cpp, line 601

###!!! ASSERTION: Creating a circular frame list, this is very bad.: 'this != aNextSibling', file /Users/jruderman/central/mozilla/layout/base/../generic/nsIFrame.h, line 802

###!!! ASSERTION: loop in frame list.  This will probably hang soon.: 'Error', file /Users/jruderman/central/mozilla/layout/generic/nsFrameList.cpp, line 604
Jesse, can you please re-confirm this assertion? I cannot reproduce it with a current trunk build on Vista and OS X.
WFM. I'll check in the testcase as a crashtest.
Flags: in-testsuite?
Flags: in-testsuite? → in-testsuite+
Closing as WFM based on comment 2. Thanks Jesse.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.