Crash [@ CheckDestructuring]

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression, testcase})

Trunk
x86
Mac OS X
crash, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

10 years ago
js> function x([y]) { }   
Crash [@ CheckDestructuring]

This kills jsfunfuzz within a second most of the time.
(Reporter)

Comment 1

10 years ago
This was a regression from the patch in bug 418051, which has been backed out.
Blocks: 418051
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 451432

Comment 3

10 years ago
/cvsroot/mozilla/js/tests/js1_7/expressions/regress-451340.js,v  <--  regress-451340.js
initial revision: 1.1

http://hg.mozilla.org/mozilla-central/rev/c908af7dfec5
Flags: in-testsuite+
Flags: in-litmus-
Crash Signature: [@ CheckDestructuring]
You need to log in before you can comment on or make changes to this bug.