[PP] Local Mail- No attachment paperclip when having weird filename for attachment

RESOLVED INVALID

Status

MailNews Core
Backend
P3
normal
RESOLVED INVALID
18 years ago
10 years ago

People

(Reporter: pmock, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
PowerPC
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Build Date & Platform Bug Found: 
 macos commercial seamonkey build 2000-071021-m17 installed on G3/400 OS 9.04

Overview Description: 
 Related to bugzilla bug 34962.  On Local Mail under POP on the Mac ...

If you send a mail with a header:
Content-Type: appl/vnd; charset=iso-8859-1;
 name="!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf"

then there is no attachment paperclip shown.

If you change the header to:
Content-Type: appl/vnd; charset=iso-8859-1;
 name="gemal.vcfgemal.vcf"

then the attachment paperclip gets shown.

This problem does not occur under IMAP, only POP.
* I will attach the original test files.

Steps to Reproduce: 
1) Save the sample test files from this bug report
2) Copies these mail files into your Local Folders located in your "Document 
Folder:Mozilla:User50:Your_profile:Mail:Local Folders"
3) Launch Seamonkey
4) Open Messenger
5) Expand the Local Folder to list your folders
6) Select the folder that contain the good message
   It should display correctly with the attachment icon
7) Select the folder that contain the bad message
   No paperclip should appear.

Actual Results: 
 The message displays but the paperclip icon does not display.

Expected Results: 
 The paperclip icon should appear.

Additional Builds and Platforms Tested On: 
 This problem does not occur on Win32 or Linux commerical seamonkey build 
2000-071009-m17.

Additional Information:
(Reporter)

Comment 1

18 years ago
Created attachment 11238 [details]
attachment with OK filename
(Reporter)

Comment 2

18 years ago
Created attachment 11239 [details]
Attachment with NOT ok filename
(Reporter)

Updated

18 years ago
QA Contact: lchiang → pmock

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M19

Updated

18 years ago
Keywords: correctness, nsbeta3

Comment 3

18 years ago
I just tried this out by sending the problem attachment from this message to a
Mac and things works just fine.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Re-open bug on Mac.

On win32 and linux, this issue is not reproducible using the same scenario.  
On macos, this problem is still reproducible using the same test messages under 
the Local Folder.

I tested using the following builds:
 win32 commercial seamonkey build 2000-092909-mn6 installed on P500 Win98
 linux commercial seamonkey build 2000-092909-mn6 installed on P200 RedHat 6.2
 macos commercial seamonkey build 2000-092911-mn6 installed on G3/400 OS 9.04
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

18 years ago
Oh well, this will have to wait.

- rhp
Status: REOPENED → ASSIGNED
Target Milestone: M19 → Future

Comment 6

18 years ago
reassigning to ducarroz
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Comment 7

18 years ago
Assign it to myself.
QA Contact: pmock → fenella

Comment 8

18 years ago
to Esther..
QA Contact: fenella → esther
(Assignee)

Comment 9

17 years ago
Peter, can you check if we still have this problem. Thanks
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla0.9.6

Comment 10

17 years ago
Peter's not here anymore. Esther, could you have someone look at this?
(Assignee)

Updated

17 years ago
Depends on: 86089
(Assignee)

Comment 11

17 years ago
The problem with the second attachment is not the characters in the file name
but rather the line ending. If you set correctly the line ending for Mac, then
the attachment show up correctly in the 3Pane window.

This bug is invalid...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → INVALID

Comment 12

17 years ago
I had to take 2nd attached msg 11239 and edit the content type to make a message 
as described for attachment 11238 [details].  Now I have 2 usable messages to view in my 
local folder.  The content type "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" 
displays differently in POP & IMAP folders across platforms regarding the 
attachment display in the attachment window. Results for attachment display:

Mac-POP "gemal.vcfgemal.vcf" displays icon=NO, text=YES
Mac=POP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" displays icon=NO,text=NO 
Windows POP "gemal.vcfgemal.vcf" displays icon=YES, text=YES
Windows POP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" icon=YES, text=NO
Linux-POP "gemal.vcfgermal.vcf" displays icon=NO, text=YES
Linux-POP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" displays icon=NO,text=NO

Mac-IMAP "gemal.vcfgemal.vcf" displays icon=NO, text=YES
Mac=IMAP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" displays icon=NO,text=YES 
Windows IMAP "gemal.vcfgermal.vcf" displays icon=YES, text=YES
Windows IMAP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" icon=YES, text=NO
Linux-IMAP "gemal.vcfgemal.vcf" displays icon=NO, text=YES
Linux-IMAP "!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" displays icon=NO,text=YES
 
The difference I see now is:
"gemal.vcfgemal.vcf" will always display the attachment name in the attach 
window
"!#\244%&/()=.,-;:_*^gemal.vcfgemal.vcf" does not disply text in the attach 
window for all 3 platforms in POP and for windows in IMAP.

Not sure if this is still invalid ducarroz, please review new results and let me 
know if this is still invalid since I'm using the same message for both tests 
only changing the content type. 
(Assignee)

Comment 13

17 years ago
I'll have to retest it...
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

17 years ago
Keywords: nsbeta3
Target Milestone: mozilla0.9.6 → mozilla0.9.9

Comment 14

17 years ago
It would be interesting to know which characters actually cause this.
Status: REOPENED → ASSIGNED
Keywords: nsbeta1
Target Milestone: mozilla0.9.9 → ---

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2

Updated

17 years ago
QA Contact: esther → trix
QA Contact: trix → stephend
Product: MailNews → Core

Comment 15

14 years ago
Old bug which seems to be invalid. If the problem still exists and is
reproducable in current builds please feel free to reopen it.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → INVALID
Target Milestone: mozilla1.2alpha → ---
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.