XUL attribute readonly disables textbox even if set to false

RESOLVED DUPLICATE of bug 118683

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 118683
10 years ago
10 years ago

People

(Reporter: Markus, Assigned: jag (Peter Annema))

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

576 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

A XUL textbox element with its readonly attribute set to false will still not be editable.

Reproducible: Always

Steps to Reproduce:
1. Create a textbox element in a XUL-Window
2. Add the attribute readonly="false"
3. Try to edit the contents
Actual Results:  
Content not editable.

Expected Results:  
Content should be editable.
(Reporter)

Updated

10 years ago
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 1

10 years ago
Created attachment 334918 [details]
XUL textbox testcase

A simple XUL window demonstrating the bug.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118683
You need to log in before you can comment on or make changes to this bug.