Closed Bug 451604 Opened 11 years ago Closed 11 years ago

Clicking preview in ctrl-tab panel doesn't work on OS X

Categories

(Firefox :: Tabbed Browser, defect)

All
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.1b2

People

(Reporter: whimboo, Assigned: dao)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080821020645 Minefield/3.1a2pre ID:20080821020645

With the implementation on bug 445497 it is possible to click on previews now. But that doesn't work on OS X because Ctrl+Click is used as a replacement for the secondary mouse button (e.g. when using Apples one button mouse) to open the context menu. If we want this behavior on OS X too should we also listen on that event? Or is there a better way, Josh?
Dão, would onmouseup instead of onclick work here?
Probably yes, I need to test it.
Duplicate of this bug: 463916
Assignee: nobody → dao
Flags: blocking-firefox3.1?
Attached patch patchSplinter Review
Attachment #347263 - Flags: review?(gavin.sharp)
Attachment #347263 - Flags: approval1.9.1b2?
Attachment #347263 - Flags: review?(gavin.sharp) → review+
Target Milestone: --- → Firefox 3.1b2
Comment on attachment 347263 [details] [diff] [review]
patch

a=beltzner
Attachment #347263 - Flags: approval1.9.1b2? → approval1.9.1b2+
Flags: blocking-firefox3.1?
http://hg.mozilla.org/mozilla-central/rev/c178fed8c09c
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified fixed using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081111 Minefield/3.1b2pre as well as the equivalent build on Tiger.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.