setting advanced configuration variable/preference mail.cc_self boolean to true does not cause self/me to be added to the recipient list of outgoing messages

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Eric Weaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: version 2.0.0.16 (20080708)

I'd like to get a copy of all mail that I send, whether originating a new message or replying to someone's message.  If I use "reply all" (ie. "Message" -> "Reply to All", or Ctrl+Shift+R), my email address is not automatically added to the recipient list.  I presume this is because the configuration variable/preference "mail.cc_self" is set to "false", so I toggle it to "true", but my email address still does not get added.   How the heck do I get Thunderbird to automatically add my email address to all outgoing messages?

Reproducible: Always

Steps to Reproduce:
1. Read a message that was sent to me from someone else.
2. While viewing the message, press "Ctrl+Shift+R".
3. Look to see if my email address is/isn't listed in the To:/CC: fields of the out-going message.
Actual Results:  
My email address is not added.  I must manually add a CC entry with my email address to each/every message that I send/reply.

Expected Results:  
A CC entry with my email address should show in the outgoing message.

Comment 1

10 years ago
(In reply to comment #0)
> How the heck do I get
> Thunderbird to automatically add my email address to all outgoing messages?

Go to your account settings, choose the Copies and Folders section, check the "Bcc these email addresses" box, and add your E-Mail address there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
Being on the "Bcc" list is not the same as being on the "Cc" list; for example, some mail filters will not detect me as being in the To and/or Cc lists.

As per the original question, what is the purpose of the "mail.cc_self"?  Shouldn't it be able to add me to the CC list?  Will this variable be fixed and/or enabled?

/Eric
You need to log in before you can comment on or make changes to this bug.