Closed Bug 451711 Opened 12 years ago Closed 12 years ago

Google Reader View Page Blank Except For Headers

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: olrrm2020, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080822033426 Minefield/3.1a2pre Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080822033426 Minefield/3.1a2pre Firefox/3.0.1

Google Reader View page is blank except for the headers at the very top of the page and the Google Reader logo. Observed in both my regular and "no add-on" profiles.

Error Console shows these errors:
Error: a.appendChild is not a function
Source file: https://www.google.com/reader/ui/1483469487-en-scroll.js?hl=en
Line: 59
 ----------
Error: aP is undefined
Source file: https://www.google.com/reader/ui/1483469487-en-scroll.js?hl=en
Line: 671

Another user observed these errors:
Error: a.appendChild is not a function
Source File: http://www.google.co.uk/reader/ui/23209 ... s?hl=en-GB
Line: 59
Error: TO is undefined
Source File: http://www.google.co.uk/reader/ui/23209 ... s?hl=en-GB
Line: 670

Google Reader worked in Nightly Build 2008082103 and fails in Nightly Build 20080822033426. I will attempt to isolate it to an hourly build and post that information ASAP.


Reproducible: Always

Steps to Reproduce:
1. Log in to Google Account.
2. Go to Google Reader (see url above).
3.
Actual Results:  
Blank page except for headers and Google Reader logo

Expected Results:  
Google Reader "home" page should display.

This is a regression.
Keywords: regression
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
It appears the regression range is at build 20080821182546 (20080821 18:25:46). Google Reader does not load in this build.

It loads properly in build 20080821173847 (20080821 17:38:47).
This looks similar to a problem sayrer mentioned on IRC.
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
bug 451678 is what I'm thinking of, not sure it's a dupe.
Blocks: landtm
Google Documents also doesn't work
Confirmed
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/Locked Shiretoko/3.1a2pre - Build ID: 20080822110429

But Google Reader seems to work here.
I'm sorry for the spam, I meant "Google Docs seemed to work here".
Same here. Reader fails, Docs works.

With the same a.appendChild and aP undefined errors.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080822033426 Minefield/3.1a2pre
Sorry I should had been more clear.

Google Docs works, but when you try to open a spreadsheet it opens, but the spreadsheet doesn't show any data.
This WORKSFORME with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080823032129 Minefield/3.1a2pre ID:20080823032129
I filed Bug 451835 for Google Docs -> Spreadsheets
Regarding spreadsheets, if fails with the following JS errors:

c[m] is not a function.  line: 296
a[m] is not a function.  line: 76
a[C] is not a function.  line: 30
a[C] is not a function.  line: 30

Sorry for the confusing comment above.
Google Reader appears fine with today's Minefield nightly--Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080823032129 Minefield/3.1a2pre Firefox/3.0.1 ID:20080823032129--for me, too.
Comment 8 and comment 11 belong in another bug, not one about Google Reader. They may belong in bug 451835 -- it's closed now, so verification would be great.

Can this bug be marked WFM? FIXED if we know the changeset that fixed it (please cite it here).

/be
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.